vvb1383
?>

Напишите программу. Ввести 8 чисел с клавиатуры и найти количество всех нечетных чисел, кратных 5.​

Информатика

Ответы

mos197653

Так как целевой язык не указан, приведу пример на SWI-Prolog.

Код

count_if_condition([], 0).count_if_condition([H|T], NC) :- cond(H), count_if_condition(T, N), succ(N, NC).count_if_condition([_|T], N) :- count_if_condition(T, N).cond(H) :- mod(H, 5) =:= 0.read_ints(0, []).read_ints(N, [X|Ints]) :- read(X), integer(X), succ(NN, N), read_ints(NN, Ints).?- read_ints(8, Ints), count_if_condition(Ints, N), nl, write("Count is "), writeln(N).
Напишите программу. Ввести 8 чисел с клавиатуры и найти количество всех нечетных чисел, кратных 5.​
Напишите программу. Ввести 8 чисел с клавиатуры и найти количество всех нечетных чисел, кратных 5.​
abcd138191

Добавление подписей данных в диаграмму

Щелкните ряд данных или диаграмму. Чтобы добавить подпись к одной точке данных, щелкните ряд данных и выделите точку.

В верхнем правом углу рядом с диаграммой нажмите кнопку Добавить элемент диаграммы Кнопка "Элементы диаграммы" и выберите Метки данных.

Чтобы изменить расположение, щелкните стрелку и выберите нужный параметр.

Если нужно отобразить подпись данных в виде пузырька с текстом, выберите пункт Выноска данных.

Чтобы сделать подписи данных более наглядными, их можно переместить в точки данных или даже за пределы диаграммы. Чтобы переместить подпись данных, перетащите ее в нужное расположение.

Если подписи визуально загромождают диаграмму, можно удалить их все или некоторые из них, выбрав нужные подписи и нажав клавишу DELETE.

Изменение вида подписей данных

Щелкните ряд данных правой кнопкой мыши, чтобы отобразить дополнительные сведения, а затем выберите пункт Формат подписей данных.

В разделе Параметры подписи в группе Включить в подпись выберите требуемые параметры.

Объяснение:

katyn76

Факториал: заводим переменную, изначально записываем в неё 1. Затем в цикле от 1 до 12 умножаем значение переменной на очередное число.

Код (Python 3):

f = 1

for n in range(1, 13):

   f *= n

print(f)

Вывод:

479001600

Произведение: заводим две переменные для сумм четных и нечетных чисел. В цикле от 1 до n в зависимости от четности очередного числа увеличиваем или ту или другую сумму. В конце результаты перемножаем.

Код (Python 3):

s_even = s_odd = 0

n = 1

while n < 19:

   if n % 2 == 0:

       s_even += n

   else:

       s_odd += n

   n += 1

print(s_even * s_odd)

Вывод:

7290

Если в условии не ошибка, и действительно в первой скобке сумма до 15, то перед print(s_even * s_odd) можно уменьшить s_odd на 17 (s_odd -= 17). Тогда ответ будет 5760

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу. Ввести 8 чисел с клавиатуры и найти количество всех нечетных чисел, кратных 5.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Isaeva_Marin1010
Тинчурина1528
donertime8
впвыпвып-Зуйков629
tigran87-87
olartamonov6
malgoblin2663
s2010av565
Natalya1895
sbarichev330
Georgievich-Zamudinovna2003
narkimry134
sayfullinmr
Лифанов_Ольга
svetkinm158