sergeyshuvalov
?>

Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результате перестановки его последней и предпоследней цифр. ЯЗЫК C++

Информатика

Ответы

juliavovo
Код#include <iostream>#include <string>#include <functional>std::string switch_first_and_last(std::string N) {    auto L = N.size() - 1;    return N[L] + N.substr(1, L - 1) + N[0];}bool take_correct_number(int &number, const std::function<bool(int)>& Q) {    do {        std::cin >> number;        if (!Q(number)) {            std::cout << "Try again." << std::endl;            continue;        }        break;    } while (true);    return true;}int main() {    int number;    take_correct_number(number, [](int x){return x > 9;});    std::cout << switch_first_and_last(std::to_string(number)) << std::endl;}
Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результа
mnkrasnova

ermekahmed007

15.10.2020

Информатика

5 - 9 классы

ответ дан

Байттан битке ауыстырған кезде қандай амал қолданылады

1

СМОТРЕТЬ ОТВЕТ

Спросите ermekahmed007 о заданном вопросе...

ответ

5,0/5

3

Участник Знаний

Бір Байт бір-бірімен қатарласа тізбек түрінде орналасқан 8 биттен, яғни екілік сан таңбаларынан тұрады. Мысалы, компьютерде “Е” әрпі 10000101, кіші “е” әрпі 10100101, “/” таңбасы 00101111, “8” саны 00111000 түрінде өңделеді. Бір Байт тек бір символды бейнелейтін ақпарат өлшеу бірлігі болғандықтан, оның көмегімен 256 символды (28=256) өрнектеуге болады. Компьютер жадының көлемі осы Байт бірлігімен өлшенеді. Ол үшін Байт бірлігінің еселік түрлері: килобайт — Кб (1 Кб=1024 Б=210Б.), мегабайт — Мб (210 Кб), гигабайт — Гб (210Мб) қолданылады. Мысалы, ЭЕМ-нің шапшаң жадының көлемі 32 Мб болса, онда 32Һ210 Байт (символ) ақпарат сақталынады. Ал, ЭЕМ-нің сыртқы жадында (магниттік дискілерінде) 1—8 Гб және одан да көп ақпарат сақтауға болады. Мысалы, 400 беті бар, әр бетінде 50 қатар, ал әр қатарда 50 таңба болатын кітаптың көлемін Байт арқылы есептесек, онда 400Һ50Һ50 = 1000000 Байт = 1 Мб (яғни көлемі 1 Гб дискі 1000 кітапты есте сақтай алады). Қатар орналасқан төрт Байт бір машиналық сөз болып есептеледі, ол 32 биттен тұрады. 64 биттен немесе 8 Байттан тұратын мәліметтер бірлігі екі еселенген машиналық сөз деп аталады. Компьютер осы машиналық сөздер тізбегін өңдейді

oniks-plus

-Текстовый тип (Текстовый тип данных в Excel) – представляет информацию как текст (строка). Если число записано в ячейку с данным типом, то приложение считает его строкой. Хотя с ним можно будет провести операции вычисления, применить его как число в некоторых функциях будет невозможно.

-Числовой тип (Числовой тип данных в Excel) – определяет информацию как число, вследствие чего с ним можно проводить любые вычисления и применять математические функции. Также в приложение Excel предлагает различные виды отображения подобного рода информации.

-Формат даты и времени (Типы данных дата и время в Excel) – представляет информацию либо как дата, либо как время, либо дата и время. По своей сути тип даты и времени является всего лишь удобным представления числовой информации и поэтому позволяет проводить математические операции с ним. Данный тип не может быть отрицательным.

-Общий формат данных – используется, когда формат не установлен. Программа сама определит, к какому формату относить те или иные данные.

Объяснение:

инфа со сайта office-menu.ru

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в результате перестановки его последней и предпоследней цифр. ЯЗЫК C++
Ваше имя (никнейм)*
Email*
Комментарий*