lidiya08083268
?>

Задача D. 8. Разнообразное пересечение Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 2 с Ограничение по памяти: 64 МБ Дан двумерный массив из N строк и M столбцов, заполненный цифрами. Найти в нем такие ячейки, чтобы строка и столбец этой ячейки содержали максимально возможное количество различных цифр. 1 <= N, M <= 1000. Вывести максимально возможное количество различных цифр X для ячейки и количество таких ячеек Y. Формат входных данных N M A11 … A1M … AN1 … ANM Формат выходных данных X Y Примеры: стандартный ввод стандартный вывод 3 3 4 1 1 2 1 3 1 3 0 1 1 2 2 3 4 1 2 3 4 В первом примере максимальный набор цифр состоит из 4 элементов (0, 1, 2, 3) для ячейки (1, 1 Во втором область максимальный набор из 3 элементов для всех ячеек.

Информатика

Ответы

Васильевич Валерьевна
Решение задачи в прикрепленном текстовом файле.
Описание алгоритма:
Полученные строки хранятся в массиве s.
Элементы массива сортируются так называемой "пузырьковой" сортировкой. Для сравнения двух строк используется функция less, возвращающая истину если первая из двух переданных в функцию строк лексикографически меньше.
А дальше дело за малым: просто выводим элементы отсортированного массива без первых трех символов (номера строк).
Единственная проблема, которая может возникнуть: на некоторых компьютерах программа не работает с русским языком. Но это уже технические проблемы. Само же решение верно.
Удачи!
Abdulganieva1367

#include <iostream> // подключаем библиотеки

#include <cstdlib>

using namespace std; // глобальное пространство имён

int main()

{

setlocale(LC_ALL,"russian"); // русский язык

int tenge;

int number = 0;

cout << "Введите сумму Вашего вклада: ";

cin >> tenge;

if(tenge==200000) // если вклад 200000

{

cout << "Ваш доход составит 13,5% в год. ";

number = number+1;

}

if(tenge==350000) // если вклад 350000

{

cout << "Ваш доход составит 14,2% в год. ";

number = number+1;

}

if(number==0) // если какая-то иная сумма

{

cout << "Требуется уточнить у менеджера процентную ставку для Вашей суммы вклада. Ожидайте.";

}

   system("pause");

   return 0; // код ошибки "0"

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача D. 8. Разнообразное пересечение Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 2 с Ограничение по памяти: 64 МБ Дан двумерный массив из N строк и M столбцов, заполненный цифрами. Найти в нем такие ячейки, чтобы строка и столбец этой ячейки содержали максимально возможное количество различных цифр. 1 <= N, M <= 1000. Вывести максимально возможное количество различных цифр X для ячейки и количество таких ячеек Y. Формат входных данных N M A11 … A1M … AN1 … ANM Формат выходных данных X Y Примеры: стандартный ввод стандартный вывод 3 3 4 1 1 2 1 3 1 3 0 1 1 2 2 3 4 1 2 3 4 В первом примере максимальный набор цифр состоит из 4 элементов (0, 1, 2, 3) для ячейки (1, 1 Во втором область максимальный набор из 3 элементов для всех ячеек.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergeevna803
vuyakovleva
vuyakovleva
lukanaft
parolmm
ckiras9
germanleon
Денис1619
kristinmk
orbbsvsupply
valerii_Georgievna915
Vladimirovna Yevtodeva
(нарисуйте дорожки в paint)
РубенШафетдинов
Chausmonk4
laktionova-natal