akopovarch
?>

решить задачу на с++ или питоне Исторически Вестерос поделен на N областей, две из которых имеют выход к морю. Много лет королевство раздирала борьба за корону, так что все дороги между областями пришли в негодность. Король Роберт поручил хранителю Севера Неду Старку построить в королевстве дороги так, чтобы из любой области можно было добраться до моря по одной или нескольким дорогам. Какое наименьшее число дорог должен построить Нед Старк, чтобы выполнить поручение короля Роберта? Формат входных данных В единственной строке входного файла содержится одно целое число N (0 ≤ N ≤ 1000) — количество областей в Семи королевствах.Формат выходных данных Единственная строка выходного файла должна содержать одно целое число — минимальное количество дорог, которое нужно построить для выполнения поручения короля Роберта.Пример:A.in A.out4 2

Информатика

Ответы

Глазкова633

Объяснение:

рлллолшчллы пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук тра3 я не знаю почему у тебя так же когда ты один ты постоянно пишешь звонишь хотя бы тоже поела и все больше ничего я не знаю почему у тебя р от меня надо было с 33333месяцев Тогда и 44беседовать

sokolowskayaa

Если будете сдавать в тестирующей системе, то вместо string, лучше использовать массив char - работает быстрее.

var n,i,k,p,mx,mxj: integer;

   s: array[1..100000] of char;

begin

 readln(n);

 for i:=1 to n do read(s[i]);

 k:=0; p:=0;

 mx:=0; mxj:=0;

 for i:=1 to n do

 begin

   if s[i]='G' then k:=k+1

   else

   begin

     if p=1 then

     begin

       p:=0;

       if s[i-1]='G' then  

       if (k>mxj) then mxj:=k;

       k:=0;

     end

     else

     begin

       if k>0 then p:=1;

       if k>mx then mx:=k;

     end;

   end;  

 end;

 if mx>mxj then k:=mx+1

 else k:=mxj+1;

 if k=1 then k:=0;

 writeln(k);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить задачу на с++ или питоне Исторически Вестерос поделен на N областей, две из которых имеют выход к морю. Много лет королевство раздирала борьба за корону, так что все дороги между областями пришли в негодность. Король Роберт поручил хранителю Севера Неду Старку построить в королевстве дороги так, чтобы из любой области можно было добраться до моря по одной или нескольким дорогам. Какое наименьшее число дорог должен построить Нед Старк, чтобы выполнить поручение короля Роберта? Формат входных данных В единственной строке входного файла содержится одно целое число N (0 ≤ N ≤ 1000) — количество областей в Семи королевствах.Формат выходных данных Единственная строка выходного файла должна содержать одно целое число — минимальное количество дорог, которое нужно построить для выполнения поручения короля Роберта.Пример:A.in A.out4 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ba5-m
alf206
arhangel1055
MikhailovnaAnastasiya
bhg50
moskvabelarus
sharovaeln6
ilyanedelev
daarisgoy
Yevgeniya Bessonov
nikolai37
stsnab
sahar81305
namik120939
diana-020
▲