Fruktova Gazaryan
?>

Доброго времени суток.) кто-нибудь может ? ибо я совсем не вывожу информатику. 1.написать программу, которая вводит массив из n целых чисел и выводит на экран элементы с чётными номерами. протестировать программу напроизвольных массивах размерностью 5 и 8 элементов. 2..написать программу, которая вводит массив из n целых чисел и выводит на экран сам массив и сумму всех его элементов. протестировать программу на следующихмассивах: а) 1 3 4 -2 б)0 1 -2 10 11 12 -10 -3 в)1 1 1 1 -1 -1 -1 -1 прошу-у-у, уделите время, если вас не затруднит.

Информатика

Ответы

info292

1)

var a: array [1..100] of integer; объявляем массив

i,n: byte; объявляем переменную i и переменную   n   для хранения количества элементов

 

begin

write('введите n = '); readln(n); вводим n

for i: =1 to n do begin от 1 до n   цикл 

write('a[',i,']=');

readln(a[i]); вводим элементы в массив

end;

write('исходный массив:   ');

for i: =1 to n do выводим наш массив полностью

write(a[i],' ');

writeln;

write('результат:   '); выводим результат, в данном случае все элементы стоящие на четных местах

for i: =1 to n do

if i mod 2 =0 then write(a[i],' '); проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент

end.

 

2)

var a: array [1..100] of integer;

i,n: byte; s: longint; s объявляем для хранения суммы элементов

 

begin

s: =0; обнуляем s

write('введите n = '); readln(n);   тут тоже самое, что и в первой

for i: =1 to n do begin

write('a[',i,']=');

readln(a[i]);

s: =s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s

end;

write('исходный массив:   ');

for i: =1 to n do   вывод массива

write(a[i],' ');

writeln('сумма всех элементов массива = ',s); вывод суммы

end.

 

удачи=)

krutikovas

var

  age : integer;

begin

  read (age);

  if (age > 50) or (age < 17) then writeln ('no') else writeln ('yes');

end.

 

var

  a, b, c, count : integer;

begin

  read (a, b, c);

  count : = 3 - a mod 2 - b mod 2 - c mod 2;

  writeln (count);

end.

 

var

  k : integer;

begin

  read (k);

  if (k mod 1000 div 100 = k mod 100 div 10) and (k div 1000 = k mod 10) then writeln ('yes')       else writeln ('no');

end.

lavorenn

мать к мастеру. Там может быть что угодно: от отвала мультика, который вы самостоятельно не диагностируете, до пробоя транзисторов в цепи питания, которые вы может и диагностируете, но не факт что там только они. Можетбыть снесён биос, может быть какие-то шинконтроллеры, или еще какая-то трудно диагностируемая фигня. Попробовав самостоятельно обычным паяльником это всё выпаять - вы с 70%-ной вероятностью сожжете плату, потому что те, кто может не сжечь плату, таких во не задают. Сейчас у вас есть шанс получить назад рабочую материнку, если вы отнесёте её к мастеру, а если полезете сами - скорее всего угробите её.

Вот и выбирайте, что вам важнее: рабочий девайс или понты.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Доброго времени суток.) кто-нибудь может ? ибо я совсем не вывожу информатику. 1.написать программу, которая вводит массив из n целых чисел и выводит на экран элементы с чётными номерами. протестировать программу напроизвольных массивах размерностью 5 и 8 элементов. 2..написать программу, которая вводит массив из n целых чисел и выводит на экран сам массив и сумму всех его элементов. протестировать программу на следующихмассивах: а) 1 3 4 -2 б)0 1 -2 10 11 12 -10 -3 в)1 1 1 1 -1 -1 -1 -1 прошу-у-у, уделите время, если вас не затруднит.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Сулейманова
Kondratev Ruzavina22
Ignateva737
rb-zakaz
tanya14757702
Railyan
olesyadeinega41
Elizavetaborisovna1992
latoyan817
alexey
lubavarif83
egolopuzenko4253
Avdeeva Inga1505
Абумислимовна_кооператив585
elozinskaya