alyonazharikowa4
?>

Напишите программу, которая запрашивает на ввод число. Если оно положительное, то на экран выводится цифра 1. Если число отрицательное, выводится -1. Если введенное число- это 0, то на экран выводится 0. Используйте в коде условный оператор множественного ветвления.​

Информатика

Ответы

asviridova07194

x = ' '

a = int(input('Enter your number:' x))

if a > 0:

print('1')

elif a < 0:

print('-1')

elif a == 1:

print('0');

dpolkovnikov
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге
sales5947
Чтобы это узнать нам потребуется разобрать это на примере.
допустим у нас есть изображение размером 1024х1024 пикселя.
чтобы определить объем занимаемой памяти при наличии на нем 65 536 цветов для начала нужно выяснить сколькими битами кодировать один пиксель.  65 536 = 2^16 => один пиксель кодируется 16 битами. 
значит объем памяти изображения будет составлять:
1024*1024*16= 16 777 216 бит.
теперь вычислим объем памяти при  наличии 16 цветов на изображении.
16=2^4 =>
1024*1024*4=4 194 304
теперь чтобы определить во сколько раз уменьшился объем памяти изображения мы выполняем следующее действие:
16 777 216 : 4 194 304 = 4
т е объем памяти изображения уменьшился в 4 раза.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая запрашивает на ввод число. Если оно положительное, то на экран выводится цифра 1. Если число отрицательное, выводится -1. Если введенное число- это 0, то на экран выводится 0. Используйте в коде условный оператор множественного ветвления.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ВасилийКлимова1695
Ekaterina1654
sergey
Коваленко
Ignateva737
Vladimirovna
modno-trikotazh
mausgaly
vlebedeva81
alapay
Zeitlinama7067
ev89036973460
Feyruz90
Dmitrievna-Dmitrii980