kuchino09
?>

информатика 10 класс 1) Массив а[1..10] заполните случайными целыми числами в диапазоне от 1 до 10. Определите , есть ли в массиве элемент , равный 5. ответ выведите в виде слов "Да" или "Нет".2) Составьте программу , которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран последний элемент с нечётным значением и его индекс. ​

Информатика

Ответы

fotostock

1. n = 2        s = 6

2. n = 7        s = 11

3. n = 20      s = 81

Объяснение:

1.

n = 2     s = 4     i = 2     2<=2   ДА

n = 2     s = 6     i = 5     5<=2   НЕТ

2.

n = 7     s =  4     i = 2     2<=7   ДА

n = 7     s =  6     i = 5     5<=7   ДА

n = 7     s = 11     i = 8     8<=7   НЕТ

3.

n = 20     s =  4      i =  2           2<=20   ДА

n = 20     s =  6      i =  5           5<=20   ДА

n = 20     s = 11       i =  8           8<=20   ДА

n = 20     s = 19      i = 11           11<=20   ДА

n = 20     s = 30     i = 14         14<=20   ДА

n = 20     s = 44     i = 17          17<=20   ДА

n = 20     s = 61      i = 20       20<=20   ДА

n = 20     s = 81      i = 23       23<=20   НЕТ

n = 2 (или 7, или 20)     s = 4     i = 2

пока условие i <= n истинно, то выполняем действия в цикле

Действия в цикле:

s = s + i

i = i + 3

Вывод s

шаг 1

n = 2     s = 4     i = 2

условие   2<=7   истинно (ДА)

Действия в цикле:

s = s + i = 4 + 2 = 6

i = i + 3 = 2 + 3 = 5

шаг 2

n = 2     s = 6     i = 5

условие   5<=2   ложно (НЕТ)

Действия в цикле не выполняются

Вывод 6

mail5

Алгоритмом называется точное и понятное предписаниe исполнителю совершить последовательность действий, направленных на решение поставленной задачи.При всем многообразии алгоритмов решения задач в них можно выделить три основных вида вычислительных процессов:

линейный;

ветвящийся;

циклический.

Компьютер

Python, JavaScript,C++

Пример программы на языке программирования Паскаль:

PROGRAM RR;

VAR A,B,C, max: INTEGER;

BEGIN

WRITE(‘ ВВЕДИТЕ A, B, C');

READLN(A,B,C);

IF A>B THEN max:=A

ELSE max:=B;

IF C>max THEN max:=C;

WRITELN(max);

END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

информатика 10 класс 1) Массив а[1..10] заполните случайными целыми числами в диапазоне от 1 до 10. Определите , есть ли в массиве элемент , равный 5. ответ выведите в виде слов "Да" или "Нет".2) Составьте программу , которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран последний элемент с нечётным значением и его индекс. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Marinanagornyak
deadnobody
IrinaSolodukhina1495
matoksana
asemchenko
Eduard Popik
martabunova
Сергеевич1386
Varvara
uksusoval617
bereza81
Бондарен1076
onboxru16
avakarica
borisov
▲