myhauz
?>

Все по порядку(Язык программирования Python) На вход подается строка, состоящая из двух слов, разделенных пробелами. Необходимо переставить эти слова в порядке убывания их длин. Формат ввода: строка из двух слов Формат вывода: строка, содержащее то же самое количество слов, но расставленных в порядке убывания их длин

Информатика

Ответы

argo951385

x =  input()

l = [str(i) for i in x.split(" ")]

res1=l[0]

res2=l[1]

if len(res1) < len(res2):

   print(res2, res1)

if len(res1) > len(res2):

   print(res1, res2)

Пример входа: app down

Вывод: down app

Valerii276
Свойства строкиПараметрыИсходная видимостьВыберите параметр, чтобы определить исходное отображение строки в отчете.ВидимыйВыберите этот параметр, чтобы отобразить строку.СкрытыйВыберите этот параметр, чтобы скрыть строку.ВыражениеЭтот параметр используется для изменения исходной видимости с выражения.Введите выражение, результатом вычисления которого являетсялогическое значение True, чтобы скрыть элемент, и False, чтобы отобразить элемент. Нажмите кнопку выражения (fx), чтобы редактировать выражение.Видимость может переключаться другим элементом отчетаВыберите этот параметр, чтобы указать, что видимость строки может изменяться при другого элемента отчета.Элемент отчетаВведите или выберите имя элемента отчета, щелкнув который, пользователь сможет изменить видимость текущей строки. Элемент отчета должен быть текстовым полем в том же группировании, или содержащим группирование в текущей строке.
lilit-yan

Как мы уже выяснили, массивы объединяют однородные единицы информации – элементы одного и того же типа. Но многообразие информации нельзя свести только к какому-то одному типу данных. Например, указывая положение точки в пространстве, мы можем воспользоваться одним и тем же типом для указания ее координат, но, описывая человека, мы должны указать его имя, рост, цвет глаз и волос, то есть в одном описании объединим разнородную информацию. Точно так же, описывая автомобиль, мы укажем не только его марку, но и год выпуска, модификацию, да и цвет кузова может нас заинтересовать. Составляя автоматизированный каталог книгохранилища, мы для каждой книги должны указать ее название, имя автора, область знания, количество страниц, год издания, а также, возможно, признак нахождения на руках или в хранилище.

Данные такого рода, описывающие существенные стороны того или иного объекта путем включения в описание нескольких, часто разнотипных, элементов, называют записью (record). В языке Паскаль запись определяется путем указания служебного слова record и перечисления входящих в запись элементов с указанием типов этих элементов.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Все по порядку(Язык программирования Python) На вход подается строка, состоящая из двух слов, разделенных пробелами. Необходимо переставить эти слова в порядке убывания их длин. Формат ввода: строка из двух слов Формат вывода: строка, содержащее то же самое количество слов, но расставленных в порядке убывания их длин
Ваше имя (никнейм)*
Email*
Комментарий*