?>
те составить программу на Java Напишите программу, которая выполняет "сжатие массива целых чисел" – переставляет все нулевые элементы в конец. При этом все ненулевые элементы располагаются в начале в том же порядке. Возможно решать задачу по-разному, например, использовать дополнительные массивы или даже не использовать массивы совсем. Главное - вывести получившуюся последовательность. Вы должны написать полностью программу на Java, один public класс с именем Main в пакете по умолчанию (в коде отсутствует подстрока package) с функцией main()), которая решает задачу. Ввод осуществляется с консоли, вывод - на консоль. Программа должна работать точно по протоколу, который показан в примерах. Например, нельзя выводить ничего лишнего, скажем, фразу "Введите N". Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N целых чисел – элементы массива. Гарантируется, что входные данные корректны и N < 10001. Выходные данные Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами. For example: Input Result 6 1 0 2 0 3 4 1 2 3 4 0 0 6 1 2 3 4 5 6 1 2 3 4 5 6
Ответы
const
N = 10;
var
a : array[1..N] of integer;
begin
randomize;
for I : byte := 1 to N do
begin
a[i] := random(1, 5);
write(a[i],' ');
end;
for I : byte := 2 to N do
if a[1] = a[i] then writeln(i);
end.
Задание #2.
const
K = 2;
N = 10;
var
a : array[1..N] of integer;
begin
for I : byte := 1 to N do
begin
readln(a[i]);
if a[i] mod k = 0 then write(a[i],' ');
end;
end.
Задание #3.
const
Z = 2;
N = 10;
var
a : array[1..N] of integer;
count : word;
begin
count := 0;
for I : byte := 1 to N do
begin
readln(a[i]);
if a[i] > Z then
begin
a[i] := Z;
Inc(count);
end;
end;
for I : byte := 1 to N do
write(a[i],' ');
writeln;
writeln(count);
end.
Стоит на на всякий случай пояснить, что N, K, Z - константы, их можно легко поменять, так гораздо удобнее работать с программой, если нужно что-то поменять. Процедура Inc( ) - прибавляет единицу, это короче чем писать Count := Count + 1; В первом задание в цикле, который ищет значение элементов массива, которые равны первому элементу массива, я начал со второго элемента. потому что очевидно, что первый элемент будет равен самому себе. Надеюсь, вам написанные мной программы, она не сложные, вам стоит внимательно их просмотреть и, вы сможете без труда их понять самостоятельно, если пожелаете, разумеется.