тахирович_Игорь581
?>

Массив содержит информацию о стоимости 20 товаров в магазине (случайные числа от 1 до 50 С клавиатуры вводятся коли-чество товаров, которые приобретает покупатель, и номера приобрета-емых товаров. Составьте программу для нахождения стоимости по-купки.​

Информатика

Ответы

nastya3213868
1) 64*32/8/1024 = 0,25 кб; 1 / 0,25 = 4 бит пиксель; 2^4 = 16 цветов.
2) 50*80*(ln(16)/ln(2)) = 16000 бит; 16000 / 8 = 2000 байт.
3) 64*64*(ln(256)/ln(2)) = 32768 бит / 8 / 1024 = 4 кбайт минимум.
4) 2048*1536*3 байт пиксель = 9437184 байт / 8 / 1024 = 1152 кбайт.
5) (ln(256)/ln(2)) / (ln(2)/ln(2)) =8 раз меньше стал; (текущий уменьшенный вес файла + 70 байт) * 8 =~ 560 байт если весил 1 байт.
6) (ln(64)/ln(2)) / (ln(8)/ln(2)) = 2 раза.
7) (ln(1024)/ln(2)) / (ln(32)/ln(2)) = 2 раза.
8) 32*64/8 = 256; 512 байт / 256 = 2 бит пикс; 2^2 = 4 цветов.
9) 128*128/8/1024 = 2; 4 кб / 2 = 2 бит пикс; 2^2 = 4 цветов.
10) 1024*768*16 бит пикс = 12582912 бит / 8 / 1024 / 1024 = 1,5 мбайт.
11) 1024*512/8/1024 = 64; 256 кб / 64 = 4 бит пикс; 2^4 = 16 цветов.
12) 32*128*(ln(64)/ln(2)) бит = 24576 бит / 8 / 1024 = 3 кбайта.
13) 2^24 = 16 777 216 цветов; 1240*1024*(ln(16777216)/ln(2)) бит пикс = 30474240 бит / 8 / 1024  = 3720 кбайт для одной страницы требуется.
 
sv-opt0076
Uses graphabc;

var
    i, c: integer;
    ar: array[1..5]of integer;

begin
  for i := 1 to 5 do read(ar[i]);
  window.IsFixedSize := true;
  window.Init(0, 0, 800, 800, clDarkGray);
  window.CenterOnScreen;
  SetFontSize(32);
  for i := 1 to 5 do c := c + ar[i].ToString.Length;
  for i := 1 to 7 do writeln;
  write(' ':33 - c);
  for i := 1 to 5 do
  begin
    if(ar[i] mod 2 = 0) and (ar[i] mod 10 <> 0) then
     begin
      SetFontColor(clred);
      write(ar[i]);
    end
    else if(ar[i] mod 10 = 0) then
      begin
      SetFontColor(clblue);
      write(ar[i]);
    end
    else if(ar[i] mod 2 <> 0) then
    begin
      SetFontColor(clyellow);
      write(ar[i]);
    end
  end;
 end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Массив содержит информацию о стоимости 20 товаров в магазине (случайные числа от 1 до 50 С клавиатуры вводятся коли-чество товаров, которые приобретает покупатель, и номера приобрета-емых товаров. Составьте программу для нахождения стоимости по-купки.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

iburejko7
sve34166163
ГармаеваЕкатерина1637
krasnobaevdj3
Ivanovich-A.V
Vik1744184
Borg Fedak1162
Каныбек698
aggeeva
ganul
platonm777639
zoocenterivanoff51
papanovar
maria
Andreeva