MDubovikov73
?>

Напишите программу на Python!! Сколько полных часов, минут и секунд содержится в s секундах? Разложите имеющееся количество секунд на сумму из x часов + y минут + z секунд.

Информатика

Ответы

Oksana-Kirakosyan1301

s = int(input())

n = s

x = 0

y = 0

z = 0

x = s // 3600

s = s - x * 3600

y = s // 60

s = s - y * 60

z = s

print('В', n, 'секундах всего', x, 'часов,', y, 'минут,', z, 'секунд')

Вывод:


Напишите программу на Python!! Сколько полных часов, минут и секунд содержится в s секундах? Разложи
angelinaugan119
Вопрос с подвохом, пропускная меряется не от возможной передачи на стороне провайдера или пользователя, а от версии протокола 2СH (2 цэ-аш). Рассмотрим 2 последние версии. Протокол 2015 года поддерживал пропускную вплоть до 20 MB/WEBM. Стандарт нового протокола поразили многих экспертов, скорость была снижена вдвое. Но сделано это было в связи с отказом многих производителей сетевого оборудования устанавливать расширяющие микросхемы PassCODE для поддержки тех самых 20 MB/WEBM. Может в будущем, с большим распространением PassCODE пропускную поднимут, но пока приходится с этими ограничениями смирится и перекодировать WEBM что несомненно, приведет к ухудшению их качества. 
Olgachalova111
//1. Переборный алгоритм Евклида (цикл repeat)

var a, b, с: integer; 

begin

  write('Введите два числа: ');

  readln(a, b);

  if a < b then с := a + 1 else с := b + 1;

repeat с := с - 1

  until (a mod с = 0) and (b mod с = 0);

  write('NOD = ', с)

end.

 

//2. Алгоритм с вычитанием (цикл while)

var  a, b: integer;

begin

  write('a = ');

  readln(a);

  write('b = ');

  readln(b);

  while a <> b do

    if a > b then

      a := a - b

    else

      b := b - a;

  writeln('NOD = ', a);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на Python!! Сколько полных часов, минут и секунд содержится в s секундах? Разложите имеющееся количество секунд на сумму из x часов + y минут + z секунд.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anatolevich-sergeevna
Novikova Aleksandrovna
Vkois56
bagramyansvetlana
zmlavra
kosharikclub
Sosovna Dmitrievich22
vladexi
Павел
egcuzn86
goldenshtein33333
gorbunova188
filial2450
marinamarinyuk39
fancy-decor67
▲