Вадим-Рашад323
?>

Программу надо написать на c++ Программу надо написать на c++ Программу надо написать на c++ Поменять местами Дано натуральное четырехзначное число, необходимо поменять местами средние цифры. Входные данные Входные данные содержат единственное целое четырехзначное число. Выходные данные В ответ напишите четырехзначное число, которое получается из исходного обменом двух средних цифр. Примечание В этой задаче запрещено использовать символьный тип данных. Программу написать надо на c++ Программу надо написать на c++ Программу надо написать на c++

Информатика

Ответы

tatarinova-51

#include <cmath>

#include <iostream>

using namespace std;

int main(){

   int a,b,c,d;

   cin >> d;

   a = d%10;

   b = d%100/10;

   c = d/100%10;

   d /= 1000;

   d = d*1000+b*100+c*10+a;

   cout << d;

   return 0;

}

Объяснение:


Программу надо написать на c++ Программу надо написать на c++ Программу надо написать на c++ Поменят
Шиловский126
1. Если число в двоичной системе заканчивается на 00, значит оно кратно 4-м в десятичной системе. То есть нужно определить, сколько существует двузначных чисел, которые в квадрате кратны 4-м.10*10
Квадрат числа будет кратен четырем в том случае, если это число чётное, то есть ответом будет кол-во четных двузначных чисел, а это 45.

2. 3 бита это 2^3 = 1 из 8 вариантов. Значит четверки - это 1/8 от всех оценок, 64/8=8 четверок

3. Всего существует 5 четных цифр (включая 0). Из них можно составить 5^4 = 625 различных четырёхзначных комбинаций.
чухловина209
Рекурсивный подход.(Символы тоже удаляет)
function grad(s:string):string;
var
i:byte;
detect:boolean;
begin
while i < length(s) - 2 do
begin
inc(i);
if (s[i] = s[i+1]) and (s[i] = s[i+2]) then {проверка последовательности из 3 елементов}
begin
delete(s,i,3); {если да - удаляем их}
detect:=True; {логическая переменная регистрирует изменение строки}
end;end;
if detect = True then
s:=grad(s); {если строку изменили , проверяем не появились ли там еще последовальности}
grad:=s; 
end;

var
s:string;
begin
readln(s);
writeln(grad(s));
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программу надо написать на c++ Программу надо написать на c++ Программу надо написать на c++ Поменять местами Дано натуральное четырехзначное число, необходимо поменять местами средние цифры. Входные данные Входные данные содержат единственное целое четырехзначное число. Выходные данные В ответ напишите четырехзначное число, которое получается из исходного обменом двух средних цифр. Примечание В этой задаче запрещено использовать символьный тип данных. Программу написать надо на c++ Программу надо написать на c++ Программу надо написать на c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rimmatrotskaia303
bieku68
Larya
avdushinalizza1
olegmgu1
skryabinamaria
bel1-79
ismailovi670771
cheremetdiana
olyaartemenko
mariashapar
tarhan1221
Марюк-Мубариз
agent-ulitka5
rudakovam198