petrosyan35
?>

БЕЗ СПАМА: PYTHON: Составьте программу для нахождения суммы, разности, произведения, частного двух (необязательно целых) чисел. Предусмотрите чтобы в случае деления на 0, выводилось сообщение "нельзя поделить на 0" Сделайте в программе возможность выбора операции.​

Информатика

Ответы

Кирилл_Гульницкий

what =input("Введите действие: +,-,*,/ " )

a = float(input("Введите первое число: "))

b = float(input("Введите второе число: "))

if what == "+":

   c = a + b

   print("Результат: " + str(c))

elif what == "-":

   c = a - b

   print("Результат: " + str(c))

elif what == "*":

   c = a * b

   print("Результат: " + str(c))

elif what == "/":

   c = a / b

   if b != 0:

       print(a / b)

   else:

       print('Деление на ноль запрещено.')

else:

   print("Выбрана неверная операция! :(")

input()

Kelena190533

Відповідь:

numb1 = float(input('Enter the first number'))

numb2 = float(input('Enter the second number'))

get_operator = str(input('Chose the operator + - * /'))

if get_operator == '+':

   print(numb1 + numb2)

elif get_operator == '-':

   print(numb1 - numb2)

elif get_operator == '*':

   print(numb1 * numb2)

elif get_operator == '/':

   if numb2 != 0:

         print(numb1 / numb2)

   else:

         print('Деление на ноль запрещено.')

else:

   print('Ошибка')

Пояснення:

Kaccak8778
Задание 1:

Program Bid;

Uses crt;

var a,b,max:integer;

begin

   write(' Введите целое число a=');

   readln(a);

   write(' Введите целое число b=');

   readln(b);

   if a>=b then max:=a

   else max:=b;

   writeln('Max=',max);

end.

Задание 2:

Program Text;

var x:integer;

begin

   write('Введите цифру 1 или любую :');

   readln(x);

   if x=1 then write(' В а с я')

   else write(' П е т я');

end.

Задание 3:

Program Text;

var x:integer;

begin

   write('Введите цифру 1, 2 или любую :');

   readln(x);

   if x=1 then write(' В а с я')

   else if x=2 then write(' П е т я')

   else write('ERROR');

end.

Задание 4:

Program MaxFrom3;

begin

  writeln('Введите 3 числа: ');

   var (a, b, c) := ReadInteger3;

   write('Наибольшее число: ', Max(a,b,c));

end.


РЕБЯТ, ОЧЕНЬ ПОЖАЙЛУСТА (Готова отдать все ) Информатика - 9 класс Задания и программы приведены ни
РЕБЯТ, ОЧЕНЬ ПОЖАЙЛУСТА (Готова отдать все ) Информатика - 9 класс Задания и программы приведены ни
РЕБЯТ, ОЧЕНЬ ПОЖАЙЛУСТА (Готова отдать все ) Информатика - 9 класс Задания и программы приведены ни
РЕБЯТ, ОЧЕНЬ ПОЖАЙЛУСТА (Готова отдать все ) Информатика - 9 класс Задания и программы приведены ни
РЕБЯТ, ОЧЕНЬ ПОЖАЙЛУСТА (Готова отдать все ) Информатика - 9 класс Задания и программы приведены ни
alukyanov

USES CRT;

VAR m1,m2,n,n1,n2,n3,n4,n5,n6,s1,s2:LongInt;

BEGIN

ClrScr;

     ReadLn(n);

  m1:=n;

   n1:=m1 div 100;

   n2:=m1 mod 10;

   n3:=(m1-n1*100-n2) div 10;

 if n1=n2 then if n1=n3 then writeln('vse =');

 if n1=n2 then writeln('1 i 3 =');

 if n2=n3 then writeln('2 i 3 =');

 if n1=n3 then writeln('1 i 2 =')

 else writeln('<>');

 END.

Проверяйте, что непонятно - спрашивайте.

Можно чуть поправить вывод, чтобы когда vse =, не вылезали 1 i 3, 1 i 2, 2 i 3.

Да и вообще writeln'ов можно наставить и переменные назвать покрасивше. но это уж вы сами, думаю, справитесь. В VAR у меня тоже есть лишние переменные, переделывал старый свой код наспех =)

Всего хорошего.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

БЕЗ СПАМА: PYTHON: Составьте программу для нахождения суммы, разности, произведения, частного двух (необязательно целых) чисел. Предусмотрите чтобы в случае деления на 0, выводилось сообщение "нельзя поделить на 0" Сделайте в программе возможность выбора операции.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ogonizoloto
Рожков Зейдан460
Manyaya
zagadka27
veniaminsem
kononova_Pavel689
Svetlana1335
museumuzl
gorbunova188
Dmitriy793
taanaami75
likakedo4ka439
andreevaalisa
yuip2008
marketing601