mgg64
?>

С клавиатуры вводятся целые числа a и b (b > a), k (k > 1), n (n > 1 Написать программу, которая выводит на экран суммы:

Информатика

Ответы

Yuliya701

Объяснение:

a)

n=int(input('n='))

s=0

for i in range(1,n+1):

   s+=1/i

print('s=',s)

б)

n=int(input('n='))

k=int(input('k='))

s=-k

for i in range(2,n+1):

   s+=(-1)**i*(k+i)/i

print('s=',s)

в)

n=int(input('n='))

a=int(input('a='))

b=int(input('b='))

s=0

n=1

while a+n<=b:

   s+=(-1)**n*(a+n-1)/(a+n)

   n+=1

print('s=',s)

г)

k=int(input('k='))

s=0

i=0

while k+i<=2*k:

   s+=(k+i)**2

   i+=1

print('s=',s)

д)

a=int(input('a='))

b=int(input('b='))

s=0

i=0

while a+i<=b:

   s+=2**(a+i)

   i+=1

print('s=',s)

cometa94558

6

Объяснение:

Между населёнными пунктами A, B, C, D построены дороги, протяжённость которых (в километрах) приведена в таблице. Определите длину кратчайшего пути между пунктами A и С. Передвигаться можно только по дорогам, протяжённость которых указана в таблице.

Сколькими можно попасть в пункт С?

Из D в C - 2 км

Из B в С - 5 см

Из А в С - 7 км

Рассмотрим п.D - из А в него 4 километра. В сумме: 2 + 4 = 6 километров.

Рассмотрим п.В - из А в него 2 километра. В сумме: 5 + 2 = 7 километров.

Из п.А в п.С напрямую - 7 километров.

Получается, что сначала надо прибыть из пункта А в пункт D, потом из пункта D в пункт С.

ответ: 6 километров.

sadkofamily61

16 Кбайт = 16 384 Байт

24 Мбайт = 24 576 Кбайт

25 Тбайт = 26 214 400 Мбайт

2 Гбайт = 2 097 152 Кбайт

12 Мбайт = 12 582 912 Байт

8 Мбайт = 67 108 864 Бит

16 Мбайт = 0,015625 Гбайт

24 Тбайт = 24 576 Гбайт

2 Мбайт = 16 777 216 Бит

1 Тбайт = 8 796 093 022 208 Бит

Объяснение:

1 Кбайт = 1024 Байт ⇒ 16 Кбайт = 16 * 1024 = 16 384 Байт

1 Мбайт = 1024 Кбайт ⇒ 24 Мбайт = 24 * 1024 = 24 576 Кбайт

1 Тбайт = 2²⁰ Мбайт ⇒ 25 Тбайт = 25 * 2²⁰ = 26 214 400 Мбайт

1 Гбайт = 2²⁰ Кбайт ⇒ 2 Гбайт = 2 * 2²⁰ = 2 097 152 Кбайт

1 Мбайт = 2²⁰ Байт ⇒ 12 Мбайт = 12 * 2²⁰ = 12 582 912 Байт

1 Мбайт = 2²³ бит  ⇒ 8 Мбайт = 8 * 2²³ = 67 108 864 Бит

1 Гбайт = 1024 Мбайт ⇒ 16 Мбайт = 16 : 1024 = 0,015625 Гбайт

1 Тбайт = 1024 Гбайт ⇒ 24 Тбайт = 24 * 1024 = 24 576 Гбайт

1 Мбайт = 2²³ бит ⇒ 2 Мбайт = 2 * 2²³ = 16 777 216 Бит

1 Тбайт = 2⁴³Бит ⇒ 1Тбайт = 1 * 2⁴³ = 8 796 093 022 208 Бит

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С клавиатуры вводятся целые числа a и b (b > a), k (k > 1), n (n > 1 Написать программу, которая выводит на экран суммы:
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

danaya3005
anton
sssashago8
is490
Андрееевич787
Михаил1121
mali2681208
Yurevich1291
snezhanaklimenkova
cernovarmechta
juliaipatova1739
ирина_Андреевич1634
yanagitsina
Dimston134877
Аношкина1696
▲