Hugokate77729
?>

с этим заданием 1 Составьте программу закрашивания буквы "П", размерами три клетки по вертикали и две по горизонтали .Начальное положение Робота-где -то в центре поля.

Информатика

Ответы

Pona4ka93

1. Переменная цикла (n) будет принимать значения от a до a+10 с шагом 2 (как и указано в описании цикла).

То есть, это будут значения: a,  a+2,  a+4,  a+6,  a+8,  a+10.


2. Увеличение величины на 1% равносильно умножению на 1,01

(ведь N + N*1% = N + N*1/100 = N + 0,01N = 1,01N).

Всего месяцев,  значит вклад шестьдесят раз был умножен на 1,01.

Такое многократное умножение на одно и то же число можно заменить умножением на соответствующую степень этого числа.

То есть, размер вклада через 5 лет будет равен:

N * 1,01⁶⁰ ≈ 1,8167N

Ivanovna

С++. Пример работы программы на изображении.

#include <iostream>

#include <ctime>

#include <cstdlib>

#include <algorithm>

#include <iterator>

#include <clocale>

#include <vector>


#define UINT unsigned int


using namespace std;


int main() {

setlocale(LC_ALL, "Russian");


int N = 20;

const int K = 13;


if(K >= N || K < 0) {

 cout << "Ошибка! Выход за прееделы массива";

 return 1;

}


double *Arr = new double[N];


/*ЗАПОЛЕНИНЕ МАССИВА СЛУЧАЙНЫМИ ЧИСЛАМИ*/

srand((UINT)time(NULL));

generate(Arr, Arr + N, []() { return rand() % 91 + 10; });


/*ВЫВОД НА ЭКРАН ИЗНАЧАЛЬНОГО МАССИВА*/

cout << "Исходный массив:" << endl;

copy(Arr, Arr + N, ostream_iterator<int>(cout, " "));

cout << endl;


/*УДАЛЕНИЕ ЭЛЕМЕНТА k*/

vector<double> bufer(Arr, Arr + N);

bufer.erase(bufer.begin() + K);

Arr = (double*)realloc(Arr, sizeof(Arr[0])*(--N));

copy(bufer.begin(), bufer.end(), Arr);


/*ВЫВОД НА ЭКРАН КОНЕЧНОГО МАССИВА*/

cout << "Результирующий массив массив:" << endl;

copy(Arr, Arr + N, ostream_iterator<int>(cout, " "));

cout << endl;


system("pause");

return 0;

}


Необходимо удалить k - ый элемент из массива т , состоящего из n элементов . ( 3 )

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с этим заданием 1 Составьте программу закрашивания буквы "П", размерами три клетки по вертикали и две по горизонтали .Начальное положение Робота-где -то в центре поля.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

OOO&quot;Kiprei&quot;_Aleksandr1938
Сергеевич1396
moidela87
mnkrasnova
tretyakovamarina201155
Скворцов
sbalashov62
yuip2008
banketvoshod
Сурат1199
Yurevich1291
maxchuev
alfakurs
Дружинин
Yelena642