jim2k
?>

Напишите программу Pascal, в которой будет выводится сообщение, что ученик сдал анализы или нет. Сдал - цифры 3, 4, 5. Не сдал - 2

Информатика

Ответы

Yelena_Irina826
1.
program pr1;
uses crt;
var n,k,i,t:integer;
begin
clrscr;
write('Введите целое число n=');
readln (n);
for i:=2 to n do begin
t:=0;
for k:=2 to n do
if i mod k=0 then t:=t+1;
if t=1 then write(i:3);
end;
readln;
end.

2.

Program pr2;
Var a, b: Integer;

Function NOD(a, b: Integer): Integer;
Var tmp, r: Integer;
Begin
If b > a Then
Begin
tmp := a;
a := b;
b := tmp;
End;
tmp := a;
While tmp > 0 Do
Begin
Result := tmp;
tmp := tmp - b;
End;
End;

Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
Write('НОД: ', NOD(a, b));
ReadLn;
End.
modellisimo-a
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

type
  Ex211a=class
 
  public
 
  constructor(fio,phone:string);
  begin
    var n:=Max(fio.Length,phone.Length);
    Writeln((n+2)*'*');
    Writeln('*',fio.PadRight(n),'*',NewLine,'*',phone.PadRight(n),'*');
    Writeln((n+2)*'*')
  end;
end;

type
  Ex211b=class
 
  public
 
  constructor;
  begin
    var n:=ReadInteger('Введите целое число:');
    Writeln('Результат равен ',n+10)
  end;
end;

begin
  new Ex211a('Иван Иванов','7-841-2666666');
  new Ex211b
end.

Пример

*Иван Иванов  *
*7-841-2666666*

Введите целое число: 18
Результат равен 28

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу Pascal, в которой будет выводится сообщение, что ученик сдал анализы или нет. Сдал - цифры 3, 4, 5. Не сдал - 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kosharikclub
donliolik
aa276568
pbttehnology
peregovorkacoffee
demon8608
gdmaslo
mihailpolehin8
forosrozhkov
volchek01112240
Михайлович1309
yana2211
Диана820
madjk
Дубровская571
▲