Барскова1943
?>

составьте программу пересчета расстояния из морских миль и кабельтовых в километры, метры и сантиметры (1 морская миля равна 1852 метра. 1 кабельтов равен 1/10 части морской мили)

Информатика

Ответы

lilit-yan

program reset;

function toMils(count,count2:integer):integer;

begin

write(count / 1852 + count2 / 1852 * 10, ' метров, ');

writeln(count / 185200 + count2 / 185200 * 10, ' сантиметров');

end;

var a,b:integer;

begin

   read(a);

   read(b);

   toMils(a, b);

end.

dokurova634
Для перевода из двоичной в шестнадцатеричный надо код разделить на тетрады (на группы по 4 цифры):
0101 1101 1000 1010 1010 1111 0010 1010
Если слева недостаточно цифр до тетрады, то слева добавляем нули.
Далее переводим тетрады в шестнадцатеричный код с таблицы:
0000 => 0        0001 => 1        0010 => 2        0011 => 3        0100 => 4
0101 => 5        0110 => 6        0111 => 7        1000 => 8        1001 => 9
1010 => A       1011 => B        1100 => C       1101 => D        1110 => E
1111 => F
0101 1101 1000 1010 1010 1111 0010 1010 = 5D8AAF2A

Для перевода в восьмеричный код делаем аналогично, только на двоичный код делим на группы по 3 цифры:
001 011 101 100 010 101 010 111 100 101 010
И также если не хватает до 3-ех цифр, то слева добавляем нули.
Затем переводим по аналогичной таблице:
000 => 0      001 => 1      010 => 2      011 => 3
100 => 4      101 => 5      110 => 6      111 => 7
001 011 101 100 010 101 010 111 100 101 010 = 13542527452
Ivanova55878
А) НОЧЬ - НОЛЬ - МОЛЬ - МЕЛЬ - ДЕЛЬ - ДЕНЬ
Дель — мелкая сеть
 
б) РОТА - НОТА - БОТА - БОЛА - ПОЛА - ПОЛК
Бота — испанский мешок для вина
Бола — испанское метательное оружие
 
в) БАНТ - КАНТ - КАРТ - КОРТ - КОРА - КОСА
 
г) БЕГ - БЕЛ - МЕЛ - МЕХ - МОХ - ЛOХ - ЛОГ - ЛАГ - ШАГ
Бел — единица громкости звука
Лoх — китайский кустарник
Лаг — прибор для измерения скорости судна
 
д) МОРЕ - МОРГ - ТОРГ - ТОРТ - СОРТ - БОРТ - БУРА - СУРА - СУША
Бура — минерал
Сура — раздел в Коране
 
е) МИГ - МИМ - ЖИМ - ЖОМ - КОМ - КОЛ - КОК - ВОК - ВЕК
Вок — китайский котёл для жарки

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

составьте программу пересчета расстояния из морских миль и кабельтовых в километры, метры и сантиметры (1 морская миля равна 1852 метра. 1 кабельтов равен 1/10 части морской мили)
Ваше имя (никнейм)*
Email*
Комментарий*
▲