ilonchick679
?>

8 кл Дано описание массива С: char C[3] = { ''A'', ''1'', ''Ю'' }; Чему равно значениеэлемента С[2]?

Информатика

Ответы

stolle16

A[i]:=random(20)-10;

while (i>0)

if i<>0

Объяснение

Ошибка A[i]:=random(21); Твой диапазон [0;20]

Исправление A[i]:=random(20)-10;

Дальше можно находить элемент в массиве по разному, можно просто все элементы проверить, счётчик дойдёт до нуля - программа выведет "Не найден!", если счётчик не равен нулю, значит хотя бы 1 значение х в массиве было найдено.

Ошибка while (i<=N)

Исправление while (i>0)

Ошибка if i<=N

Исправление if i<>0

Условие (i<=N) выполняется всегда, поэтому оно вообще не нужно

Olybetezina1973

C# 8.0:

using System;

...

public static void InsertToArr<T>(ref T[] Arr, in T Value, in int Index){

   T[] NewArr = new T[Arr.Length + 1];

   for (int i = 0; i < Index; i++) NewArr[i] = Arr[i];

   NewArr[Index] = Value;

   for (int i = Index + 1; i < NewArr.Length; i++) NewArr[i] = Arr[i-1];

   Arr = NewArr;

}

...

Console.ReadLine(); //skips N

var Arr =Array.ConvertAll(Console.ReadLine().Split(' '),int.Parse);

var temp = Console.ReadLine().Split(' ');

InsertToArr(ref Arr, int.Parse(temp[0]), int.Parse(temp[1])-1);

foreach (int i in Arr) Console.Write(i + " ");

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

8 кл Дано описание массива С: char C[3] = { ''A'', ''1'', ''Ю'' }; Чему равно значениеэлемента С[2]?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sveta300856729
vvk2008
shugayzhanna6
Test Станислав
temik10808564
nikiforovako76
apro3444595
laplena1982750
zaravshan20134
ganorussia
Ляпунов_Владмирович
vodexshop2
stalker2201
zoosalon-hollywood5
yulyazhdan
▲