pereverzev
?>

Определите количество различных выплаты сдачи в размере n рублей купюрами 10 рублей и монетами 5, 2 и 1 рубль. Например, 5 рублей можно выплатить четырьмя различными нужно на питоне

Информатика

Ответы

bryzgalovag
1. Program A1;
var
s,m:integer;
begin
Writeln('Vvedi vozrast SASHI :');
Read(s);
Writeln('Vvedi vozrast MASHI :');
 Read(m);
If s>m then writeln('SASHA starshe MASHI') else writeln('MASHA starshe SASHI');
end.

2.
Program A1;
var
s,m:integer;
begin
Writeln('Vvedi vozrast SASHI :');
Read(s);
Writeln('Vvedi vozrast MASHI :'); 
Read(m);
If s=m then writeln('SASHA i MASHA rovestniki') else
If s>m then writeln('SASHA starshe MASHI') else writeln('MASHA starshe SASHI');
end.

3.
Program A1;
var
a,b,c,d:real;
begin
Readln(a);
Readln(b);
Readln(c);
If ((b<a) and (b<c)) then begin d:=a; a:=b; b:=d; end;
If ((c<a) and (c<b)) then begin d:=a; a:=c; c:=d; end;
If ((a>b) and (a<c)) then begin d:=b; b:=a; a:=d; end;
If ((c<b) and (c>a)) then begin d:=b; b:=c; c:=d; end;
If ((a>c) and (a>b)) then begin d:=c; c:=a; a:=d; end;
If ((b>c) and (b>a)) then begin d:=c; c:=b; b:=d; end;
writeln(a,'<',b,'<',c);
end.
Овезова Игорь
Const n=3;
var    a: array[1..n] of integer;  
  i, j, k: integer; 
begin  
  randomize;   
  write ('Исходный массив: ');  
  for i := 1 to n do begin  
      a[i] := random(256);     
   write (a[i]:4);    end;    
writeln; writeln;    
  for i := 1 to n-1 do   
     for j := 1 to n-i do   
         if a[j] > a[j+1] then begin     
           k := a[j];            
    a[j] := a[j+1];        
        a[j+1] := k        
    end;    
 write ('массив по возрастанию: '); 
   for i := 1 to n do  
     write(а[i]:4);   
  writeln;
 readln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите количество различных выплаты сдачи в размере n рублей купюрами 10 рублей и монетами 5, 2 и 1 рубль. Например, 5 рублей можно выплатить четырьмя различными нужно на питоне
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fab2004
Belik-elena20111
Fedorovich_Aleksandrovich685
erere4443
nusupova
АльбертовичБерезин58
Банова_Елена431
KonovalovKonstantinovna1306
cheremetdiana
spz03
Кожуховский398
stperelyot7833
tarhan1221
arina2403423
mariyachervonnaya44