sbn07373
?>

1)Облачные сервисы, в зависимости от целей бывают и назначения ? 2) Выберите информационные процессы, которые используются в облачных сервисах ? 3) К какому виду относится среда программирования Microsoft Visual C++

Информатика

Ответы

katrin50

===== С++ 17 =====

#include <iostream>

using namespace std;

void swap(int &a, int &b)

{

   int t = a;

   a = b;

   b = t;

}

int main()

{

   int n;

   cin >> n;

   int a[n];

   srand(time(NULL));

   for(int i = 0; i < n; i++)

   {

       a[i] = rand() % 198 - 99;

       cout << a[i] << " ";

   }

   cout << endl;

   bool perm = false;

   int j;

   for(int i = 0; i < n - 1; i++)

   {

       if(a[i] > a[i + 1])

       {

           swap(a[i], a[i + 1]);

           j = i;

           perm = true;

           while(perm && (j > 0))

               if(a[j] < a[j - 1])

               {

                   perm = true;

                   swap(a[j], a[j - 1]);

                   j--;

               }

               else perm = false;

       }

   }

   for(int i = 0; i < n; i++)

       cout << a[i] << " ";

   cout << endl;

   return 0;

}


Необходимо написать программу, сортирующую случайный массив следующим метод является модификацией пу
Ligacom

Объяснение:

в первой программе предоставлен алгоритм сортировки выбором и он выведет (если не считать что строки там сьехали и будет ошибка если так вбить) [11, 12, 22, 25, 34, 64, 90]

вторая программа

в переменную а запишется [3,9,14,8,2,11]

в переменную b результат сортировки питона  [2, 3, 8, 9, 11, 14]

в переменную с [3,9,14,2, 3, 8, 9, 11, 14]

выведет он [3,9,14,2, 3, 8, 9, 11, 14]

третья программа

выведет то что дано а потом отсортированный массив по второму элементу так как нумерация начинается с нуля

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)Облачные сервисы, в зависимости от целей бывают и назначения ? 2) Выберите информационные процессы, которые используются в облачных сервисах ? 3) К какому виду относится среда программирования Microsoft Visual C++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

srkushaev
lebedevevgen
Дмитриевич_Скрябин931
zaravshan20134
Тимур
kattarina71
mpityk
Стефаниди
lalaland2744
Васильевий
hotnuts
zakup-r51
Вячеславовна_Сагитович
e-s-i-k
kalterbrun