Поделитесь своими знаниями, ответьте на вопрос:
решить: 1.Напишите программу, которая в последовательности целых чисел определяет количество двузначных чисел, кратных 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество двузначных чисел, кратных 8. 2.Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3.
Відповідь:
Пояснення:
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int n, i, j,p, s;
float sr;
cin>>n;
int arra[n];
for(i=0; i<n; i++)
cin>>arra[i];
for (int i = 1; i<n; i++)
{
if (arra[i] > 0){
s = s + arra[i];
p = p + 1;
}
}
sr = s/p;
printf("%.2f",sr);
cout<<endl;
cout<<"[ ";
for(int i = n - 1; i >=0; i--)
cout<<arra[i]<<" ";
cout<<"]"<<endl;
return 0;
}