eidevyatkina
?>

Написать программу на языке Паскаль : Определить наличие в строке S подстроки Х. Вывести на экран соответствующее сообщение.

Информатика

Ответы

Виктория1690

begin

 var s := ReadString('Введите строку:');

 var x := ReadString('Введите подстроку строку:');

 

 if Pos(x, s) <> 0 then

   Print('Подстрока присутсвует')

 else

   Print('Подстрока отсутсвует');

end.

mariashapar
Отношение объектов и множеств.

Отношение - это взаимная связь, в которой находятся какие либо объекты.

Виды отношений:
1) Объект-объект
2) Объект-множество
3) Множество-множество

Отношения множеств можно легко показать с кругов Эйлера.

Виды отношений между множествами:
1) Множества пересекаются.
Это значит,что у множеств есть общие единицы. Например, множество людей, говорящих на башкирском и множество людей, говорящих на русском. Но есть люди, говорящие на двух языках. Это и есть пересечение множеств.
2) Множества не пересекаются.
Это значит,что у множеств нет одинаковых частей, они не пересекаются.
3) Множества равны
Это значит, что элементы в двух мнлжествах одинаковы
4) Подмножество
Бывает так, что в одном множестве есть ещё одно множество. Оно называется подмножество. Например: множество людей, а у него подмножество дети.
vgolentsova

14.9 (равнобедренные трапеции (с комментариями)):

#S=1/2h(a+b)

print ('Введите первое основание для первой трапеции')

af=int(input()) # Первое основание первой

print('Введите второе основание для первой трапеции')

bf=int(input()) # Второе основание первой

print('Введите высоту для первой трапеции')

hf=int(input()) # Высота первой

print ('Введите первое основание для второй трапеции')

aas=int(input()) # Первое основание второй

print ('Введите второе основание для второй трапеции')

bs=int(input()) # Второе основание второй

print ('Введите высоту для второй трапеции')

hs=int(input()) # Высота второй

pf=(af+bf)+af-bf)/2)**2+hf**2)**0.5)*2 #Периметр первой

ps=(aas+bs)+aas-bs)/2)**2+hs**2)**0.5)*2 #Периметр второй

sf=(af+bf)*hf/2 # Площадь первой

ss=(aas+bs)*hs/2 #Площадь второй

print ('Сумма периметров=', pf+ps)

print ('Сумма площадей=', sf+ss)

14.23 (Трехзначные простые числа):

for a in range (100,1000):

   b=0

   for i in range (2,a):

       if a%i==0:

           b+=1

   if b==0:

       print(a)

P.S: Вставлено из среды разработки, проверку на компиляторе программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Паскаль : Определить наличие в строке S подстроки Х. Вывести на экран соответствующее сообщение.
Ваше имя (никнейм)*
Email*
Комментарий*