ranocchio6
?>

Тема «Циклические алгоритмы» Цикл со счетчиком 1. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a:=10; for i:=1 to 2 do begin a:=a-2; end; 2. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a:=3; for i:=1 to 2 do begin a:=a+a; end; 3. Какое число будет выведено на экран после выполнения этого фрагмента программы? write(1); for i:=3 to 5 do write(i); Цикл с предусловием 1.Сколько раз будет выполнен этот цикл? i:=5; while i 3); 2. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 4 раза? i:=...; repeat writeln('Привет!'); i:=i+1; until (i=9); 3. Какое число будет выведено на экран в результате выполнения этого цикла? i:=6; write('9'); repeat write(i); i:=i+1; until(i>5);

Информатика

Ответы

seleznev1980
Program a1;
var a,b: array [1..10] of integer; 
n,i,k,sum,c: integer;
begin
Randomize;
For i:=1 to 10 do 
   begin     
      a[i]:=random(100);     
       write(a[i]:3);   
   end;    
Readln (n);   
For i:=1 to 10 do 
   begin 
     k:=a[i];
     while k>0 do 
                    begin 
                         sum:=sum+(k mod 10);
                        k:=k div 10;
                    end; 
        f (n=sum) then  
          begin
              inc(c);     
              b[c]:=a[i];      
          end; 
 end;
for i:=1 to c do  
write(b[i]:2); 
end.
Lolira64
1) Program dasf;
var a,b,i,s: integer;
begin
Writeln('Введите четырёхзначное число');
readln(a);
For i:=1 to 4 do
begin
S:=a mod 10+s;
a:=a div 10
end;
writeln('Сумма цифр четырёхзначного числа:',s);
end.
2)Program sgsgsdfg;
var a,b,c,a1,b1,c1: real;
begin
Writeln('Введите а');
readln(a);
Writeln('Введите b');
readln(b);
Writeln('Введите c');
readln(c);
If (a=b) or (a=c) then a1:=a*a 
else a1:=a*2;
If (b=a) or (b=c) then b1:=b*b 
else b1:=b*2;
If (c=a) or (c=b) then c1:=c*c 
else c1:=c*2;
Writeln('Полученные числа: а=',a1,' b=',b1,' c=',c1);
end.
3) Program afgsdg;
var n,a,b,i: integer;
begin;
Writeln('Введите число');
readln(a);
Writeln('Введите степень');
readln(n);
b:=a;
For i:=2 to n do   
a:=a*b;
Writeln('Число ',b,' в степени ',n,' равно ',a);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Тема «Циклические алгоритмы» Цикл со счетчиком 1. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a:=10; for i:=1 to 2 do begin a:=a-2; end; 2. Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a:=3; for i:=1 to 2 do begin a:=a+a; end; 3. Какое число будет выведено на экран после выполнения этого фрагмента программы? write(1); for i:=3 to 5 do write(i); Цикл с предусловием 1.Сколько раз будет выполнен этот цикл? i:=5; while i 3); 2. Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 4 раза? i:=...; repeat writeln('Привет!'); i:=i+1; until (i=9); 3. Какое число будет выведено на экран в результате выполнения этого цикла? i:=6; write('9'); repeat write(i); i:=i+1; until(i>5);
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mariya Filippov
Sergei248
sky-elena712558
Pavlovna897
AntonovaAvi1716
StudioArtNails
bogatskayaa
ktatarinova
ars-trushakova
dnikolay365
N-odes-art-school410
delfa-r6289
annarom1306
Elenazhukovafashion7
Наталья_Васищев