zuzman601
?>

1. Напишите программу (файл TakeInput.py), которая просит пользователя что-нибудь ввести с клавиатуры. Если он вводит какие-нибудь данные, то на экране должно выводиться сообщение "ОК". Если он не вводит данные, а просто нажимает Enter, то программа ничего не выводит на экран. 2. Напишите программу (файл PosNeg.py), которая запрашивает у пользователя число. Если оно больше нуля, то в ответ на экран выводится число 1. Если введëнное число не является положительным, то на экран должно выводиться -1.

Информатика

Ответы

kormilitsynarita

TakeInput.py:

В 1 строчку:

[pass if input() == "" else print("OK")] # ничего если пробел иначе OK

На понятном языке:

string = input() # просим пользователя ввести что-то

if string == "": # если он нажал пробел (ничего не ввел)

   pass # ничего не делаем

else: # иначе

   print("OK") # ввыводим OK

PosNeg.py:

В 1 строчку:

[print(1) if int(input()) > 0 else print(-1)] # исправил на > 1 извини опечатка в скрине

На понятном языке:

num = int(input()) # пользователь вводит число и мы его преобразуем в целочисленное

if num > 0: # если число больше 0 то

   print(1)  # выводим 1

else: # иначе

   print(-1) # выводим -1


1. Напишите программу (файл TakeInput.py), которая просит пользователя что-нибудь ввести с клавиатур
Kostyuchik-Astakhov531
//Pascal
  var a,b, I, maxsumm, max : integer;
 
  function summdel(x:integer):integer; //результат - сумма делителей х
  var k,sum:integer;
  begin
    sum:=0;
    for k := 1 to x div 2 + 1 do
      if x mod k = 0 then sum:= sum+k;
    summdel:=sum;
  end;
 
  begin
   writeln('Введите границы a,b ');
   readln(a,b);
    maxsumm := 1;
    max := 1;
    for i := a to b do
     begin
        if summdel(i) > maxsumm then
          begin maxsumm:= summdel(i);
            max := i;
          end;
     end;
     writeLn('Максимальная сумма делителей - ', maxsumm, ' число - ',max)
  end.
Kochinev4
Для всех заданий воспользуемся формулой N=2^i? где N -количество цветов, а i -количество бит на 1 пиксель.
Задача 1.
N=2^4=16 цветов.

Задача 2.
N=224=2^i, поскольку для кодирования 128 цветов необходимо 7 бит, а для кодирования 256 цветов -8 бит, выбираем большее число, то есть 8 бит или 1 байт.

Задача 3.
65536 это 2^16⇒требуется 16 бит или 2 байта.

Задача 4.
1. Узнаем общее количество пикселей 1280*1024=1310720
2. Полученное число умножаем на глубину цвета 1310720*32=41943040 бит = 41943040/8 = 5242880 байт = 5242880/1024 = 5120 кб =5120/1024 = 5 Мб
ответ: 5 Мб

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Напишите программу (файл TakeInput.py), которая просит пользователя что-нибудь ввести с клавиатуры. Если он вводит какие-нибудь данные, то на экране должно выводиться сообщение "ОК". Если он не вводит данные, а просто нажимает Enter, то программа ничего не выводит на экран. 2. Напишите программу (файл PosNeg.py), которая запрашивает у пользователя число. Если оно больше нуля, то в ответ на экран выводится число 1. Если введëнное число не является положительным, то на экран должно выводиться -1.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natalya2321
vetrov1
irinalav2705745
nzagrebin363
Татьяна_Вологжин
olkay
delfinmos
larson96
varvara-kulkova
Николаевна1564
Мария-Кострыгина175
shabaev19542355
Aivazyan
Natysya7777
Smolkovaya