Tatgri
?>

Напишите программу, оптимизирующую диаметр и высоту тонкой жестяной банки объемом один литр, исходя из минимума затрат на металл, пошедший на ее изготовление Язык программирования: любой. Желательно Pascal или Python3

Информатика

Ответы

evamining
P.S.

Тернарная операция в C++ - это выражение вида (b ? x : y) (где b - логическое выражение, а x и y - одного типа). Она вернёт x, если выражение b истинно, и y, если b ложно.


Решение

В приложении расписаны координаты некоторых клеток, а также помечены точками те, которые по цвету отличаются от не помеченных. Если поискать, что у них общего, можно обнаружить, что у "невыколотых" клеток сумма координат по горизонтали и вертикали - чётная. Это "свойство" и используем для определения цвета клетки.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

 int x1, y1, x2, y2;

 cin >> x1 >> y1 >> x2 >> y2;

 cout << ((x1 + y1) % 2 == (x2 + y2) % 2 ? "YES" : "NO") << endl;

 return 0;

}



На с++ с тернарной операцией поле шахматной доски определяется парой натуральных чисел, каждое из ко
Karlova1507

Давай сравним все 4 числа между собой, найдём максимальное и вычтем из него N.


Код

#include <bits/stdc++.h>

using namespace std;

int main() {

   int a, b, c, d, n;

   cin >> a >> b >> c >> d >> n;

   if (a > b && a > c && a > d)

       a -= n;

   else if (b > a && b > c && b > d)

       b -= n;

   else if (c > a && c > b && c > d)

       c -= n;

   else d -= n;

   cout << a << " " << b << " " << c << " " << d << endl;

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, оптимизирующую диаметр и высоту тонкой жестяной банки объемом один литр, исходя из минимума затрат на металл, пошедший на ее изготовление Язык программирования: любой. Желательно Pascal или Python3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

legezin
dashanna04225
Zhanibekrva Kandaurova
Dato24043846
zuzazuza61
steam22-9940
saryba
ilyushin-e
olgolegovnak
VadimovnaIgor
Вадим
Viktoriya
kashihina
kirillreznikov
yakushkinayuliya