elena-vlad822828
?>

Написать программу на языке Python: Записать условие (составить логическое выражение), которое является истинным, когда: Только одно из чисел X, Y , Z кратно трем можете ответить на другой вопрос в моем профиле, там больше

Информатика

Ответы

perova-s200

def xyz(x, y, z):

   def count_of_divided_by_3(values):

       result = 0

       for i in values:

           if i % 3 == 0:

               result += 1

       return result

   if count_of_divided_by_3([x, y, z]) == 1:

       return True

   return False

print(xyz(5, 6, 2))

ayk111560
Прога написанная в codeblocks: #include < iostream> using namespace std; int main() {          setlocale(lc_all,"russian");           int a[20];           int b, c, i, q=0;           for(i=1; i< 21; i++)          {                  cout< < "введите "< < i< < " число: ";                   cin> > a[i];           }          cout< < "введите начальный номер элемента массива: ";     cin> > b;     cout< < "введите конечный номер элемента массива: ";     cin> > c;     for(int j=b; j< c+1; j++)          {                q+=a[j];         }          cout< < "cумма элементов массива с номерами с "< < b< < " по "< < c< < " равна: "< < q; } я надеюсь тебе была нужна прога на с++))
mv7095

Каждый год около тысячи команд со всей Японии вступают в ожесточенное сражение на турнире роботов. В этом состязании вы не увидите бензопил, факелов и электрических разрядов — словом, ничего из того, что приходит в голову, когда вы слышите фразу «битва роботов».

Речь идет не просто о битве — это робо-сумо, которое ценят за особые качества: за элегантность, простоту и возможность проявить интеллект в стратегии. Соревнование проходит на круглом металлическом ринге диаметром всего 1,5 м, по периметру которого нарисована белая линия шириной 5 см. Робот, пересекший эту границу, считается проигравшим. И в этой кажущейся простоте кроется бездна возможностей.

Расскажем, как «битва роботов» стала интеллектуальным соревнованием для программистов, и дадим подробную инструкцию по сборке робо-сумоиста.Глаза робота — датчики инфракрасного излучения. Степень ИК-отражения измеряется светочувствительным элементом. Белый цвет границы выбран не случайно — он отражает больше света, чем черная поверхность ринга.

Робот оснащен несколькими ИК-датчиками, ответственными за «поиск» границы. Передние датчики, как правило контролировать скорость движения — боец не должен покинуть поле из-за чрезмерной ретивости. Тыловые датчики «следят» за приближением к границе ринга: получив от них отклик, робот меняет направление движения.

А измеряя время, необходимое для отражения лучей, можно понять местоположение противника. Многие роботы (но не все) меняют направление, учитывая этот параметр.Помимо перечисленных преимуществ, у ИК-датчиков есть и недостаток — поле зрения остается узким, за счет чего появляется множество слепых зон, использование которых в атаке — основная стратегия высокоманевренных роботов.

Однако это работает только с автономными роботами. Когда самостоятельный робо-сумоист сталкивается с радиоуправляемым противником, он не может использовать стратегию атаки слепых зон, так как оператор видит больше, чем робот.

Вместо того чтобы атаковать слепые точки, автоботы применяют стратегию атаки с углов. В целом же у борца не так много доступных маневров: поворот, толкание, торможение и остановка.

Однако чтобы запутать противника некоторые бойцы выбрасывают белые флаги с одной или с двух сторон корпуса. Заманивая противника к флагу, они атакуют его уязвимую сторону и выталкивают с ринга.

Конечно, появились и защиты от такой атаки. Появление флажков слева и справа означает, что корпус робота находится в центре. Если же робот выбросил флаг с одной стороны, то его корпус находится в противоположном месте.

Некоторые боты могут не только заманивать противника, но и скрываться от его датчиков. Для этого их красят в черный цвет или добавляют отражающие покрытия.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Python: Записать условие (составить логическое выражение), которое является истинным, когда: Только одно из чисел X, Y , Z кратно трем можете ответить на другой вопрос в моем профиле, там больше
Ваше имя (никнейм)*
Email*
Комментарий*