Liliya_Ivanova
?>

РЕШИТЬ ЭТУ ЗАДАЧУ НА ПАСКАЛЬ Имеется N гор Каждая гора это треугольник, основание которого лежит на оси х. Обе стороны горы наклонены под углом 45 градусов, поэтому пик горы - угол в 90 градусов. Гора i поэтому задаётся координатами (xi yi) ее газпика. Никакие две горы не имеют одно и то же расположение пикаТребуется посчитать все видимые горы Но, поскольку все они примерно одного цвета невозможно увидеть гору, если ее пик лежит на границе или внутри другой горы.Определите количество различных пиков (и следовательно гор), которые можно увидеть.Формат ввода (файл mountains.im):Первая строка ввода содержит N. Каждая из оставшихся N строк содержит хi (0<xis1019) и уi (1syjs109) описывающих пики гор.Формат вывода (файл mountains.out):Выведите минимальное количество гор, которые можно различить.Пример ввода3467225Пример вывода2​​

Информатика

Ответы

федороа

#include <iostream>

#include <vector>

#include <fstream>

#include <algorithm>

using namespace std;

class pacient {

private:

 string lastName_m, mOrFM_m, adress_m, diagnosis_m;

public:

 pacient(string lastName = "", string mOrFM = "", string adress = " ", string diagnosis = " ") {

  lastName_m = lastName;

  mOrFM_m = mOrFM;

  adress_m = adress;

  diagnosis_m = diagnosis;

 }

 string getLastName() {

  return lastName_m;

 }

 string getAll() {

  return lastName_m + ", " + mOrFM_m + ", " + adress_m + ", " + diagnosis_m + ".";

 }

};  

int main() {

fstream out("output.txt");

setlocale(LC_ALL, "Russian");

vector<pacient> arr;

for(int i = 0;;++i) {

 string a[4];

 for(int j = 0; j<4; ++j) {

  switch(j) {

   case 0: cout << "Last name: "; break;

   case 1: cout << "Male or FeMale: "; break;

   case 2: cout << "Adress: "; break;

   case 3: cout << "Diagnosis: "; break;

  }

  getline(cin, a[j]);

 }

 pacient temp(a[0], a[1], a[2], a[3]);

 cout << "Для окончания ввода введите 1: ";

 arr.push_back(temp);

 string temp1;

 getline(cin, temp1);

 if(temp1=="1") {

  break;

 }

}

for(int j = 0; j<1000; ++j) {

for(int i = 0; i<arr.size()-1; ++i) {

 if(arr[i].getLastName()[0]>arr[i+1].getLastName()[0]) {

  swap(arr[i], arr[i+1]);

 }

} }

for(int i = 0; i<arr.size(); ++i) {

 cout << arr[i].getLastName() << endl;

 out << arr[i].getAll();

 out << "\n";

}

out.close();

}


С++ Создайте текстовый файл, содержащий сведения о пациентах глазной клиники: фамилия пациента, пол,
С++ Создайте текстовый файл, содержащий сведения о пациентах глазной клиники: фамилия пациента, пол,
ЛаринаЛощаков

Первое,что приходит на ум - это Web-дизайнер.

Web-дизайнер — это человек, обладающий художественным вкусом и знаниями интернет-технологий, который создает Web-страницы и объединяет их в Web-сайты. Главная задача web-дизайнера — оформить интернет-проект так, чтобы как можно больше пользователей им заинтересовалось.

Профессия веб-дизайнера связана и с современными технологиями, и с творчеством. Этот специалист занимается оформлением проектов в интернете: разрабатывает дизайн сайтов, промо-страниц, лэндингов, электронных презентаций. Web-дизайнер создаёт логотипы, баннеры, инфографику и другие графические элементы страницы, продумывает размещение текста.

При этом web-дизайнер сосредотачивается не только на визуальном оформлении, он должен заботиться и об удобстве пользования сайтом – его юзабилити. В своей работе он применяет знания языка разметки документов HTML, языка оформления стилей документов CSS, основы HTML-вёрстки.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕШИТЬ ЭТУ ЗАДАЧУ НА ПАСКАЛЬ Имеется N гор Каждая гора это треугольник, основание которого лежит на оси х. Обе стороны горы наклонены под углом 45 градусов, поэтому пик горы - угол в 90 градусов. Гора i поэтому задаётся координатами (xi yi) ее газпика. Никакие две горы не имеют одно и то же расположение пикаТребуется посчитать все видимые горы Но, поскольку все они примерно одного цвета невозможно увидеть гору, если ее пик лежит на границе или внутри другой горы.Определите количество различных пиков (и следовательно гор), которые можно увидеть.Формат ввода (файл mountains.im):Первая строка ввода содержит N. Каждая из оставшихся N строк содержит хi (0<xis1019) и уi (1syjs109) описывающих пики гор.Формат вывода (файл mountains.out):Выведите минимальное количество гор, которые можно различить.Пример ввода3467225Пример вывода2​​
Ваше имя (никнейм)*
Email*
Комментарий*