Ахмедшина Трубников1249
?>

Написать программу на СИ : Дана последовательность целых чисел, оканчивающаяся нулем. Определить, является ли эта последовательность арифметической прогрессией

Информатика

Ответы

mereninka7008
количество используемых знаков для шифровки 2 (· и -)
с знака можно зашифровать 2 сигнала, а именно: · и -
с знаков можно зашифровать 4=2² сигнала, а именно: · ·, · -, - · и - -
с знаков можно зашифровать 8=2³ сигнала, а именно: · · ·, · · -,
· - ·, - · ·, - - ·, - · -, · - - и - - -
с знаков можно зашифровать 16=2^4 сигнала, а именно: · · · ·,
· · · -, · · - ·, · · - -, · - · ·, · - · -, · - - ·, · - - -, - · · ·, - · · -, - · - ·, - · - -, - - · ·, - - · -,
- - - · и, наконец, - - - -

для нахождения количества символов, закодированных с точки и тире длиной не менее (два и более) двух и не более четырех (четыре и менее) сигналов, необходимо сложить возможные варианты их:
2²+2³+2^4=4+8+16=28
Sergei_Olga658
1.

program xopow1;
   uses   crt;
   var  
 a, b, Sek: integer;  
begin  
writeln('Введите границы:');  
repeat    
readln(a, b);  
until b >= a;  
 clrscr;  
for a := a to b do
    begin    
Sek := a * 60;    
writeln(a, ' мин. = ', sek, ' сек.')  
end
end.

2.

program xopow2;
  uses crt; 
Var
 z:integer;
 f,x,y:real; 
Begin 
clrscr; 
Writeln;
X:=10000;
Y:=(x/100)*10;
for z:=1 to 7 do 
 Begin 
X:=x+y; 
Writeln(Z,' -й день тренировок спортсмен пробежал ',X:3:2,' Км.'); 
End; 
Writeln('Нажмите Enter...'); 
Readln; 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на СИ : Дана последовательность целых чисел, оканчивающаяся нулем. Определить, является ли эта последовательность арифметической прогрессией
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Galina-Marat1096
kbndbyb6
petrosyan35
Stroeva19651938
krisrespect2
snip99
спец387
apetrov54
partners
palmhold578
zaha98
luksorsps20096124
AHO436
Тоноян
Karmelita1978
▲