andre6807
?>

с заданиями, а то здесь вообще ничего не понятно. 1. Выберите правильный вариант ответа: Массив - это…A) упорядоченная последовательность данных, состоящая из конечного числа элементов, имеющих один и тот же тип, и обозначаемая одним именем. Б) упорядоченная последовательность данных, состоящая из конечного числа элементов, имеющих разный тип, и обозначаемая одним именем.B) упорядоченная последовательность данных, состоящая из бесконечного числа элементов, имеющих один и тот же тип, и обозначаемая одним именем.2. В каких вариантах программа будет выдавать ошибку:A) var y: array [1…10] of string;y: array [0…10] of string;y:=x;Б) var x: array [1…10] of real;y: array [0…15] of real;y:=х;B) var x, y: array [-5…20] of integer;y:=x; Г)var y: array [1…10] of string;y: array [0…10] of real;y:=x;Д) var x, y: array [0…15] ofreal;y:=x;3. Опишите массивы, если:A) элементы массива содержат стоимость 15 блюд в школьной столовой (в рублях и копейках); Б) элементы массива содержат количества мячей, забитых на чемпионате мира 16 игроками футбольной команды;B) в поезде вагоны с номерами с 6 по 14 - грузовые. Элементы массива содержат вес груза в грузовых вагонах поезда в тоннах.4. Запишите двумя функцию, с которой случайным образом формируются элементы массива из отрезка [15, 37].5. Заполните пропуски в программе, которая осуществляет ввод значений элементов массива из п вещественных чисел с клавиатуры и выводит элементы массива на экран в строку через пробел. Var c: _[1.._] of _n: integer; begin write ('Ввеите размерность массива:');readln(_ ); writeln ('Введите элементы массива:'); for var i:=_ to_ do read(c[i]); writeln ('Вывод массива: '); for var i:= _ to _ do_ end.

Информатика

Ответы

sveta300856729

Казалось бы легкие задачи, а не получается...

Заранее огромное Вычислить среднее арифметическое тангенсов трех вещественных чисел.

Входные данные:

Во входном потоке в первой строке задано три вещественных числа. Значения чисел по модулю не превышают 1 000 000 000.

Выходные данные:В выходной поток вывести одно вещественное число с точностью пять знаков после запятой.

0

Лучшие ответы (1)

Сообщение: #3619519

QA

Эксперт

41792 / 34177 / 6122

Регистрация: 12.04.2006

Сообщений: 57,940

27.10.2012, 19:48

ответы с готовыми решениями:

Вычислить среднее арифметическое тангенсов трех вещественных чисел

Вычислить среднее арифметическое тангенсов трех вещественных чисел. Входные данные: Во входном...

Найти среднее арифметическое трех вещественных чисел, заданных с клавиатуры

найти среднее арифметическое трех вещественных чисел, заданных с клавиатуры

Вычислить среднее арифметическое двух заданных вещественных чисел

Вычислить среднее арифметическое двух заданных вещественных чисел. Входные данные: Во входном...

Вывести массив из 50 вещественных чисел от 20 до 40, вычислить среднее арифметическое , посчитать количество элементов.

Добрый день.Задали задание, в паскале я только начинающий. Ничего не могу понять, как и что...

2

CodeR

Фрилансер

3402 / 2799 / 3000

Регистрация: 08.02.2012

Сообщений: 7,606

Записей в блоге: 1

28.10.2012, 08:55 2

Лучший ответ Сообщение было отмечено Cкорпион как решение

Решение

PascalВыделить код

1

2

y:=sin(a)/cos(a)+sin(b)/cos(b)+sin(c)/cos(c);

writeln(y/3:0:5);

так как в Паскале Abc нет стандартной функции tg поэтому выражаем через sin and cos

1

Cкорпион

1 / 1 / 5

Регистрация: 27.10.2012

Сообщений: 46

28.10.2012, 08:58  [ТС] 3

Цитата Сообщение от Artem7 Посмотреть сообщение

PascalВыделить код

1

2

y:=sin(a)/cos(a)+sin(b)/cos(b)+sin(c)/cos(c);

writeln(y/3:0:5);

так как в Паскале Abc нет стандартной функции tg поэтому выражаем через Думаю, если с тангенсами (как и с синусами и косинусами в паскале) разобраться, то ничего трудного в них не будет.

0

28.10.2012, 08:58

Answers

Эксперт

37091 / 29110 / 5898

Регистрация: 17.06.2006

Сообщений: 43,301

28.10.2012, 08:58

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

Определить среднее арифметическое вещественных чисел

Даны натуральное число п и вещественные числа а1, а2, ..., а10 . Определить среднее арифме-тическое...

Дан файл вещественных чисел. Найти среднее арифметическое его элементов

Дан файл вещественных чисел. Найти среднее арифметическое его элементов.

Даны вещественные числа а1, а2, ..., а10. Определить среднее арифметическое вещественных чисел

1)Вычислить приближенно площадь фигуры, об¬разованной кривой у == 0,3(х — l)2+4, осью абс¬цисс и...

Дан файл вещественных чисел. Найти среднее арифметическое его элементов

дан файл вещественных чисел. найти среднее арифметическое его элементов.

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:

3

ответ Создать тему

Объяснение:

miha23727

 class Program

   {

       static void Main(string[] args)

       {

           Console.WriteLine("Введите число a:");

          int a = Convert.ToInt32(Console.ReadLine());

           Console.WriteLine("Введите число b:");

          int b = Convert.ToInt32(Console.ReadLine());

           Console.WriteLine("Введите число c:");

           int c = Convert.ToInt32(Console.ReadLine());//Вводим 3 числа

           int sredAref = a + b + c / 3;//Считаем

           Console.WriteLine("Среднее Арифметическое : " + sredAref);// Выводим

           Console.ReadKey();

       }

   }

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с заданиями, а то здесь вообще ничего не понятно. 1. Выберите правильный вариант ответа: Массив - это…A) упорядоченная последовательность данных, состоящая из конечного числа элементов, имеющих один и тот же тип, и обозначаемая одним именем. Б) упорядоченная последовательность данных, состоящая из конечного числа элементов, имеющих разный тип, и обозначаемая одним именем.B) упорядоченная последовательность данных, состоящая из бесконечного числа элементов, имеющих один и тот же тип, и обозначаемая одним именем.2. В каких вариантах программа будет выдавать ошибку:A) var y: array [1…10] of string;y: array [0…10] of string;y:=x;Б) var x: array [1…10] of real;y: array [0…15] of real;y:=х;B) var x, y: array [-5…20] of integer;y:=x; Г)var y: array [1…10] of string;y: array [0…10] of real;y:=x;Д) var x, y: array [0…15] ofreal;y:=x;3. Опишите массивы, если:A) элементы массива содержат стоимость 15 блюд в школьной столовой (в рублях и копейках); Б) элементы массива содержат количества мячей, забитых на чемпионате мира 16 игроками футбольной команды;B) в поезде вагоны с номерами с 6 по 14 - грузовые. Элементы массива содержат вес груза в грузовых вагонах поезда в тоннах.4. Запишите двумя функцию, с которой случайным образом формируются элементы массива из отрезка [15, 37].5. Заполните пропуски в программе, которая осуществляет ввод значений элементов массива из п вещественных чисел с клавиатуры и выводит элементы массива на экран в строку через пробел. Var c: _[1.._] of _n: integer; begin write ('Ввеите размерность массива:');readln(_ ); writeln ('Введите элементы массива:'); for var i:=_ to_ do read(c[i]); writeln ('Вывод массива: '); for var i:= _ to _ do_ end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ВладимировнаАлександр1421
kondrashovalf6404
Varagyan1728
natalia595977
alexk13
nikitavertiev98400
kogakinoa
nekrasovaolga27
mamanger
ПетросовичЗаславский
ars-trushakova
aaazovcev
gordeevadesign2986
ti2107
olgavbaranova
▲