ekattatarenko
?>

Вводится строка, представляющая собой строку из программы на языке Pascal с комментарием . Коментарий -последовательность символов, заключенная в фигурные скобки.Составьте программу удаления комментария очень надо

Информатика

Ответы

dakimov

1.3апустить на выполнение файл «WlnAVR-20100110-install.exe» (29 Мбайт), находящийся на прилагаемом компакт-диске. Этот файл при необходимости можно свободно скачать из Интернета . Инсталлировать WlnAVR по умолчанию в папку C:\WinAVR-20100110\.

2. Открыть редактор PN2: «Пуск - Программы - WinAVR-20100110 - Programmers Notepad ». Включить нумерацию строк: «Tools - Options - General - Default - <поставить «галочку» возле «Show Line Numbers»> - ОК».

3. Создать в редакторе PN2 новый Си-файл: «File - New - С/С++». Ввести с клавиатуры текст программы  и сохранить его на жёстком диске: «File - Save As… - <ввести путь и имя файла, например, для однозначности C:\1001\demol.c> - ОК».

Здесь и далее снимки экранов (скриншоты) для экономии места будут показываться только в самых важных точках действий. Остальные скриншоты в пошаговом режиме можно посмотреть на видеоуроках в прилагаемом компакт-диске.

Пояснения к листингу.

Строка 1 начинается с комментариев, которые ограничиваются слева двумя наклонными линиями «прямой слеш». Весь текст после знаков «//» может быть о чём угодно, на любом языке, с любыми вольностями и сокращениями. Это произвольная информация, которую программист пишет для самого себя, любимого, чтобы через месяц-другой вспомнить, о чём, собственно, шла речь. Обычно указывается краткое название программы и авторство.

Строка 2 тоже содержит комментарии, но уже технического плана. Здесь расписана электрическая схема подключения индикатора HL1 и кнопки SB1 к конкретным линиям портов MK. Названия сигналов соответствуют раскладке из дашита на MHKpocxeMyATmega48A

gallows-warlike-0z
var
  a, b, c, d, i, n, p: integer;
  x, y: real;

begin
  writeln('Задача 1, введите n =');
  read(n);
  for i := 1 to n do
    if i mod 2 = 0 then
      x := x + 1 / (2 * i + 1)
    else x := x - 1 / (2 * i + 1);
  writeln('Sum = ', x);
 
  writeln('Задача 2, введите a, b, c, d =');
  read(a, b, c, d);
  for i := a to b do
    if i mod c = d then writeln(i);
 
  writeln('Задача 3, введите n и n чисел =');
  read(n);
  a := 0; b := 0; c := 0;
  for i := 1 to n do
  begin
    read(p);
    if p = 0 then a := a + 1
    else if p < 0 then b := b + 1
    else if p > 0 then c := c + 1;
  end;
  writeln(a, ' ', b, ' ', c);
 
  writeln('Задача 5, введите x, p ,y =');
  read(x, p, y);
  n := 0;
  repeat
    x := round(x * (100 + p)) / 100;
    n := n + 1;
  until x >= y;
  writeln(n, ' лет');
 
  writeln('Задача 6, введите A, B =');
  read(a, b);
  repeat
    if (a mod 2 = 0) and (a div 2 >= b) then begin
      writeln(a, ' : 2 = ', a div 2);
      a := a div 2
    end
    else begin
      writeln(a, ' - 1 = ', a - 1);
      a := a - 1;
    end;
  until a <= b;
end.
gabramova
var
  a, b, c, d, i, n, p: integer;
  x, y: real;

begin
  writeln('Задача 1, введите n =');
  read(n);
  for i := 1 to n do
    if i mod 2 = 0 then
      x := x + 1 / (2 * i + 1)
    else x := x - 1 / (2 * i + 1);
  writeln('Sum = ', x);
 
  writeln('Задача 2, введите a, b, c, d =');
  read(a, b, c, d);
  for i := a to b do
    if i mod c = d then writeln(i);
 
  writeln('Задача 3, введите n и n чисел =');
  read(n);
  a := 0; b := 0; c := 0;
  for i := 1 to n do
  begin
    read(p);
    if p = 0 then a := a + 1
    else if p < 0 then b := b + 1
    else if p > 0 then c := c + 1;
  end;
  writeln(a, ' ', b, ' ', c);
 
  writeln('Задача 5, введите x, p ,y =');
  read(x, p, y);
  n := 0;
  repeat
    x := round(x * (100 + p)) / 100;
    n := n + 1;
  until x >= y;
  writeln(n, ' лет');
 
  writeln('Задача 6, введите A, B =');
  read(a, b);
  repeat
    if (a mod 2 = 0) and (a div 2 >= b) then begin
      writeln(a, ' : 2 = ', a div 2);
      a := a div 2
    end
    else begin
      writeln(a, ' - 1 = ', a - 1);
      a := a - 1;
    end;
  until a <= b;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вводится строка, представляющая собой строку из программы на языке Pascal с комментарием . Коментарий -последовательность символов, заключенная в фигурные скобки.Составьте программу удаления комментария очень надо
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dmitrychekov9
Fedorova_79166180822
Golubitskaya378
morozov1605
Элизбарян
Dmitrii sergei463
ПетросовичЗаславский
chizhenkovd9
galinazajceva781
Semenovt
gurman171
avdeevau807
Irina_Nikolai
anna241273
rukodelnizza1