var
a: array[1..1000] of real;
i, k, n, z: integer;
begin
writeln('введите число n: ');
readln(n);
writeln('введите число z: ');
readln(z);
writeln('введите ',n,' действительных чисел (каждое с новой строки): ');
for i : = 1 to n do
begin
readln(a[i]);
if a[i] > z then
begin
a[i] : = z;
k : = k + 1;
end;
end;
writeln('количество замен: ', k);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Исходное положение робота показано на рисунке 3.49 где-то справа от робота есть закрашенная клетка расстояние до клетки может быть различным. Составьте программу в результате которой робот дойдет до закрашенной клетки.
я бы хотел съездить в город бийск, потому что там красиво, особенно в алтайских горах. горы почти достают до неба. внизу они зеленые от растущего вокруг леса. выше — светлые, а верхушки — совсем бело-голубые. я бы хотел побывать на священном ручье, который несет чистую ледяную воду с гор в реку катунь. недалеко от ручья есть дерево желаний. каждый может подойти к нему, загадать желание и привязать к его ветвям ленточку. и красуется это дерево, как разноцветная ёлка. еще я бы хотел побывать на том месте, где сливаются реки бия и катунь, образуя реку обь. и с приятными воспоминаниями и впечатлениями вернуться домой.
ich möchtein die stadtgehen, weil esbijskist sehr schön,vor allem in deraltai-gebirge.diebergehat fastbis zumhimmel.an der unterseitesind siegrünauswachsen rund umden wald.above -licht, und dietop -nur dieblau und weiß.ich möchteden heiligenbach, derein reinesgletscherwasseraus den bergendes flusseskatunist, zu besuchen.in der nähe desbachesgibt es einen baumwünsche.jeder kannkommenund sich etwas wünschenund binden sie esan die zweigedes bandes.undschmückten denbaum alsbunten baum.ich möchte auchan die stelle, wo die flüssekatunundbiya,bildenden flussobbesuchen.undmit angenehmenerinnerungen und erfahrungenwieder nach hause.