sharaeva-is
?>

Заводные жуки в квадрате Написать программу на python, отвечающую этим требованиям Есть такая математическая задача, в которой жуки двигаются из четырех углов квадрата всегда в направлении соседнего жука с одинаковой скоростью и в одном направлении. Нужно найти расстояние, которое пройдет каждый жук до встречи в центре квадрата. Задача решается легко, если перейти в систему отсчета одного из жуков и понять, какое расстояние ему нужно пройти. Хотя траектория движения жуков довольно сложная — это логарифмическая спираль. Немного изменим условие. PIC У нас будут двигаться механические жуки. Такой жук движется одну секунду по своей стороне квадрата, затем мгновенно определяет положение ближайшего спереди и справа жука, поворачивает к нему и снова движется одну секунду по стороне уже меньшего квадрата. Так продолжается, пока сторона квадрата, по которой движется жук, не станет меньше или равна расстоянию, которое он должен пройти за секунду. Теперь траектория жука — это ломаная линия. Найдите количество поворотов, которые пришлось сделать каждому жуку. Формат ввода На отдельных строках вводятся 2 вещественных числа: сторона квадрата и скорость жука в секунду. Формат вывода Целое число — количество поворотов жука. Пример Ввод Вывод 2 3 1 Примечания Поскольку в этой задаче нужно сравнивать вещественные числа, давайте это делать с точностью до сотых. abs(x − y) <= 0.01

Информатика

Ответы

Yelena Kotova

from math import sqrt

dist = float(input())

speed = float(input())

i = 0

while dist - speed > 0.01:

   dist = sqrt((dist - speed) ** 2 + speed ** 2)

   i += 1

print(i)

Объяснение:

gavrilasmax05

Каждый язык программирования имеет свои типы числовых данных, а также методы и операции для работы над ними. Не волнуйтесь: среди программистов далеко не все являются математическими гениями. Если бы все были математическими гениями, то не писали бы глючных веб-приложений, и могли ездить на дорогих гоночных автомобилях.

Все авторские права на этот материал принадлежат исключительно сайту Информатика. В случае обнаружения нарушения условий копирования наших материалов, будут предприняты соответствующие санкции к нарушителям: обращение к хостинговой компании и другие меры в соответствии с действующим законодательством РФ. Источник материала: http://inphormatika.ru/programming/python/chislovye_tipy_dannyh_v_pitone.html

Объяснение:

bogdanovaoksa

ответ: Формы представления информационных моделей.

Модели материальные и модели информационные.

Объектов моделирования огромное количество. И для того, чтобы ориентироваться в их многообразии, необходимо все это классифицировать, то есть каким-либо образом упорядочить, систематизировать.

При классификации объектов по «родственным» группам необходимо выделить некий единый признак (параметр, а затем объединить те объекты, у которых он совпадает).

Все модели можно разбить на два больших класса: модели предметные (материальные) и модели информационные. Предметные модели воспроизводят геометрические, физические и другие свойства объектов в материальной форме (глобус, анатомические муляжи, модели кристаллических решеток, макеты зданий и сооружений и др.).

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заводные жуки в квадрате Написать программу на python, отвечающую этим требованиям Есть такая математическая задача, в которой жуки двигаются из четырех углов квадрата всегда в направлении соседнего жука с одинаковой скоростью и в одном направлении. Нужно найти расстояние, которое пройдет каждый жук до встречи в центре квадрата. Задача решается легко, если перейти в систему отсчета одного из жуков и понять, какое расстояние ему нужно пройти. Хотя траектория движения жуков довольно сложная — это логарифмическая спираль. Немного изменим условие. PIC У нас будут двигаться механические жуки. Такой жук движется одну секунду по своей стороне квадрата, затем мгновенно определяет положение ближайшего спереди и справа жука, поворачивает к нему и снова движется одну секунду по стороне уже меньшего квадрата. Так продолжается, пока сторона квадрата, по которой движется жук, не станет меньше или равна расстоянию, которое он должен пройти за секунду. Теперь траектория жука — это ломаная линия. Найдите количество поворотов, которые пришлось сделать каждому жуку. Формат ввода На отдельных строках вводятся 2 вещественных числа: сторона квадрата и скорость жука в секунду. Формат вывода Целое число — количество поворотов жука. Пример Ввод Вывод 2 3 1 Примечания Поскольку в этой задаче нужно сравнивать вещественные числа, давайте это делать с точностью до сотых. abs(x − y) <= 0.01
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natakrechko
oooviktoria17
metegina4
marychev55
svo1961
olimov9
Zelinskaya-Andrei
Amelin-Alipova
myudanova631
Zelinskaya-Andrei
Винников724
zakup-r51
me576
Dragun1684
Альберт Татьяна