Синоптики фиксировали дневные температуры в течение месяца (случайные числа от 20 до 30 Составьте программу для на- хождения максимальной и минимальной температуры за месяц.
var s, k: integer; //Объявление двух целочисленных переменных
begin
s:=0; //Инициализация переменной s
for k:= 4 to 7 do //Запуск цикла по переменной k от 4 до 7
//Тело цикла
s:=s+8; //На каждом шаге цикла значение переменной s увеличивается на 8
Рассмотрим подробнее:
1 шаг цикла:
k = 4; s:=0+8;
2 шаг цикла:
k = 5; s:=8+8;
3 шаг цикла:
k = 6; s:=16+8;
4 шаг цикла:
k = 7; s:=24+8;
//Цикл закончился. На данный момент в переменной s хранится значение 32.
writeln(s); //Выводим на экран значение, которое хранится в переменной s, т.е значение 32;
end. //Конец программы
2.
var s, k:integer; //Объявление целочисленных переменных s, k.
begin
s:=0; //Инициализация переменной s
for k:= 3 to 8 do //Запуск цикла по переменной k от 3 до 8
//Тело цикла
s:= s+9; //На каждом шаге цикла значение переменной s увеличивается на 9.
Рассмотрим подробнее:
1 шаг цикла:
k = 3; s:=0+9;
2 шаг цикла:
k = 4; s:=9+9;
3 шаг цикла:
k = 5; s:=18+9;
4 шаг цикла:
k = 6; s:=27+9;
5 шаг цикла:
k = 7; s:=36+9;
6 шаг цикла:
k = 8; s:=45+9;
//Цикл закончился. На данный момент в переменной s хранится значение 54.
writeln(s); //Выводим на экран значение, которое хранится в переменной s, т.е значение 54;
end. //Конец программы
3.
Натуральные числа - числа, возникающие естественным образом при счёте (1, 2, 3, 4, 5, 6, 7 и так далее...)
Код программы:
var
count, n:integer; //Объявление целочисленных переменных. В переменной count будет храниться количество натуральных чисел в промежутке от 1 до n.
begin
write('Введите значение N: ', #10);
readln(n); //Вводим с клавиатуры значение и записываем её в нашу целочисленную переменную n. Примечание: n должна быть больше 1.
for var i:= 1 to n do //Запуск цикла по переменной i от 1 до n.
count:=count+1; //На каждом шаге цикла значение в переменной count будет увеличиваться на 1.
write('Количество натуральных чисел от 1 до ', N, ': ', count, #10); //Выводим на экран значение переменной count.
end. //Конец программы
4.
Натуральные числа - числа, возникающие естественным образом при счёте (1, 2, 3, 4, 5, 6, 7 и так далее...)
Код программы:
const // Задаём два константных значения. В нашем случае это очень удобно, т.к нам заранее известны значения от чего и до чего нужно считать произведение.
a = 12; //В переменную а записываем значение 12. В ходе программы оно меняться не может, т.к объявлена в качестве константы.
b = 14; //В переменную b записываем значение 14. В ходе программы оно меняться не может, т.к объявлена в качестве константы.
var
product: integer; //Объявляем переменную product целочисленного типа, в которой будет храниться значение произведения.
begin
product := 1; //Инициализируем переменную product. Почему не 0, а 1: Всё очень просто. Если мы запишем здесь 0, то наше произведение всегда будет равно 0. Потому что 0*на любое число = 0.
for var i := a to b do //Запуск цикла по переменной i от a до b. Т.е от 12 до 14.
product := product * i; //На каждом шаге цикла значение переменной product будет меняться таким образом.
Рассмотрим подробнее ход цикла:
1 шаг цикла:
i = 12; product:=1*12;
2 шаг цикла:
i = 13; product:=12*13;
3 шаг цикла:
i = 14; product:=156*14;
Цикл заканчивает свою работу. В данный момент в переменной product хранится значение 2184.
write('Произведение натуральных чисел от 12 до 14 = ', product, #10); //Выводим на экран значение переменной product, т.е 2184.
end. //Конец программы
antongenfon
20.01.2023
В фактографических БД содержатся краткие сведения об описываемых объектах, представленные в строго определенном формате. Например, в БД библиотечного каталога хранятся библиографические сведения о каждой книге: год издания, автор, название и пр. Разумеется, текст книги в ней содержаться не будет. В БД учащихся школы хранятся анкетные данные об учениках: фамилия, имя, отчество, год и место рождения и т. д. База данных законодательных актов в области уголовного права и база данных современных песен наверняка будут организованы как документальные. Первая из них будет включать в себя тексты законов; вторая — тексты и ноты песен; биографическую и творческую справочную информацию о композиторах, поэтах, исполнителях; звуковые записи и видеоклипы. Следовательно, документальная БД содержит обширную информацию самого разного типа: текстовую, графическую, звуковую. Т. е. фактографическая база данных содержит краткую информацию об объектах БД а документальная - расширенную.
1.
var s, k: integer; //Объявление двух целочисленных переменных
begin
s:=0; //Инициализация переменной s
for k:= 4 to 7 do //Запуск цикла по переменной k от 4 до 7
//Тело цикла
s:=s+8; //На каждом шаге цикла значение переменной s увеличивается на 8
Рассмотрим подробнее:
1 шаг цикла:
k = 4; s:=0+8;
2 шаг цикла:
k = 5; s:=8+8;
3 шаг цикла:
k = 6; s:=16+8;
4 шаг цикла:
k = 7; s:=24+8;
//Цикл закончился. На данный момент в переменной s хранится значение 32.
writeln(s); //Выводим на экран значение, которое хранится в переменной s, т.е значение 32;
end. //Конец программы
2.
var s, k:integer; //Объявление целочисленных переменных s, k.
begin
s:=0; //Инициализация переменной s
for k:= 3 to 8 do //Запуск цикла по переменной k от 3 до 8
//Тело цикла
s:= s+9; //На каждом шаге цикла значение переменной s увеличивается на 9.
Рассмотрим подробнее:
1 шаг цикла:
k = 3; s:=0+9;
2 шаг цикла:
k = 4; s:=9+9;
3 шаг цикла:
k = 5; s:=18+9;
4 шаг цикла:
k = 6; s:=27+9;
5 шаг цикла:
k = 7; s:=36+9;
6 шаг цикла:
k = 8; s:=45+9;
//Цикл закончился. На данный момент в переменной s хранится значение 54.
writeln(s); //Выводим на экран значение, которое хранится в переменной s, т.е значение 54;
end. //Конец программы
3.
Натуральные числа - числа, возникающие естественным образом при счёте (1, 2, 3, 4, 5, 6, 7 и так далее...)
Код программы:
var
count, n:integer; //Объявление целочисленных переменных. В переменной count будет храниться количество натуральных чисел в промежутке от 1 до n.
begin
write('Введите значение N: ', #10);
readln(n); //Вводим с клавиатуры значение и записываем её в нашу целочисленную переменную n. Примечание: n должна быть больше 1.
for var i:= 1 to n do //Запуск цикла по переменной i от 1 до n.
count:=count+1; //На каждом шаге цикла значение в переменной count будет увеличиваться на 1.
write('Количество натуральных чисел от 1 до ', N, ': ', count, #10); //Выводим на экран значение переменной count.
end. //Конец программы
4.
Натуральные числа - числа, возникающие естественным образом при счёте (1, 2, 3, 4, 5, 6, 7 и так далее...)
Код программы:
const // Задаём два константных значения. В нашем случае это очень удобно, т.к нам заранее известны значения от чего и до чего нужно считать произведение.
a = 12; //В переменную а записываем значение 12. В ходе программы оно меняться не может, т.к объявлена в качестве константы.
b = 14; //В переменную b записываем значение 14. В ходе программы оно меняться не может, т.к объявлена в качестве константы.
var
product: integer; //Объявляем переменную product целочисленного типа, в которой будет храниться значение произведения.
begin
product := 1; //Инициализируем переменную product. Почему не 0, а 1: Всё очень просто. Если мы запишем здесь 0, то наше произведение всегда будет равно 0. Потому что 0*на любое число = 0.
for var i := a to b do //Запуск цикла по переменной i от a до b. Т.е от 12 до 14.
product := product * i; //На каждом шаге цикла значение переменной product будет меняться таким образом.
Рассмотрим подробнее ход цикла:
1 шаг цикла:
i = 12; product:=1*12;
2 шаг цикла:
i = 13; product:=12*13;
3 шаг цикла:
i = 14; product:=156*14;
Цикл заканчивает свою работу. В данный момент в переменной product хранится значение 2184.
write('Произведение натуральных чисел от 12 до 14 = ', product, #10); //Выводим на экран значение переменной product, т.е 2184.
end. //Конец программы