Rubber-soul
?>

Напишите программу, которая позволит проверять пароль на сложность. воспользуйтесь строковыми , описанными в разделе 4.7.1. string methods ( org/3.6/library/stdtypes.html#str.isupper проверку пароля следует проводить по таким критериям: 1. длина: от 5 символов. 2. буквы латинского алфавита в верхнем и нижнем регистре: a, a, z, z. 3. цифры: от 0 до 9. 4. символы: @, #, %, & . 35

Информатика

Ответы

Japancosmetica
Const   n=10; var   a: array[1..n] of integer;   b: array[1..n] of integer;     i: integer;   sum: integer; begin {заполнение массивов случайными числами} randomize; for i: =1 to n do begin     a[i]: =random(100)-50;     b[i]: =random(100)-50; {или b[i]=a[i]; , если значения  массива b должны совпадать со значениями массива a  } end; {поиск суммы отрицательных элементов} sum: =0; for i: =1 to n do    if a[i]< 0 then sum: =sum+a[i]; {замена нулевых элементов массива b на полученную сумму} for i: =1 to n do   if b[i]=0 then b[i]: =sum; {вывод значений массива a} writeln('массив a'); for i: =1 to n do   write(a[i],','); writeln(''); writeln('массив b'); {вывод значений массива b} for i: =1 to n do   write(b[i],','); {ожидание нажатия клавиши return от пользователя.} readln; end.
viktort889841
Var   n,m,i,k: integer;     sum, qty: integer; begin   readln(m);   n: =25;   sum: =0;   qty: =0;   randomize;   for i: =1 to n do begin     k: =random(2000)-1000;     if (k mod m)=0 then begin         sum: =sum+k;           inc(qty);     end;     end;   if qty=0 then   writeln('кратных  ', m, '   чисел нет') else   writeln('среднее значение чисел  кратных ',m,' равно  ', sum/qty); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая позволит проверять пароль на сложность. воспользуйтесь строковыми , описанными в разделе 4.7.1. string methods ( org/3.6/library/stdtypes.html#str.isupper проверку пароля следует проводить по таким критериям: 1. длина: от 5 символов. 2. буквы латинского алфавита в верхнем и нижнем регистре: a, a, z, z. 3. цифры: от 0 до 9. 4. символы: @, #, %, & . 35
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

prostopo4ta29
Михеев557
IAleksandrovna45
memmedovallahverdi0239
anton-www1
djikia88
Fruktova Gazaryan
впвыпвып-Зуйков629
Asplaksina
katrin50
sanseth5
info2
dentalfamily
Annabill1987
myudanova631