Lerkinm
?>

Напишите программу, которая принимает три положительных числа и определяет, существует ли невырожденный треугольник с такими сторонами. (python)

Информатика

Ответы

silicon-films3375

python 3.8 Дальше забыла сорри

gavrilasmax05
(18 чисел)                                                                                                                     101,102,103,120,130,123,132,201,203,230,213,210,301,302,320,312,321,310.
lolydragon

Если будете сдавать в тестирующей системе, то вместо string, лучше использовать массив char - работает быстрее.

var n,i,k,p,mx,mxj: integer;

   s: array[1..100000] of char;

begin

 readln(n);

 for i:=1 to n do read(s[i]);

 k:=0; p:=0;

 mx:=0; mxj:=0;

 for i:=1 to n do

 begin

   if s[i]='G' then k:=k+1

   else

   begin

     if p=1 then

     begin

       p:=0;

       if s[i-1]='G' then  

       if (k>mxj) then mxj:=k;

       k:=0;

     end

     else

     begin

       if k>0 then p:=1;

       if k>mx then mx:=k;

     end;

   end;  

 end;

 if mx>mxj then k:=mx+1

 else k:=mxj+1;

 if k=1 then k:=0;

 writeln(k);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая принимает три положительных числа и определяет, существует ли невырожденный треугольник с такими сторонами. (python)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

мурувватовна викторович569
Наталья_Владимир708
Чем отличается телеграф от телефона
info126
lorsam36
emmakazaryan290
Pastel-sova
aprelevka
dentalfamily
akarabut343
Kharkina1328
cholga69
prik-galina7390
inna-zub
Жукова_Петрович1281
info-mosbalkon