николаевич-Елена988
?>

напишите программу , которая считывает два целых числа a и b и выводит на экран квадрат суммы (a+b)^2 и сумму квадратов a^2 + b^2 этих чисел (python )

Информатика

Ответы

marinamarinazmeeva2444

Как создать свой Layout с элементами (LinearLayout,Spinner,View и т.п.) внутри так, чтобы управлять их расположением и анимацией?

main_activity.xml:

   <LinearLayout

       android:id = "@+id/window_1"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_1"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_1"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_2"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_2"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_2"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_3"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_3"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_3"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

   <LinearLayout

       android:id = "@+id/window_4"

       android:layout_width="200dp"

       android:layout_height="100dp"

       android:orientation="vertical">

       <Spinner

           android:id="@+id/WindowSpinner_4"

           android:layout_width="match_parent"

           android:layout_height="?attr/actionBarSize"/>

       <FrameLayout

           android:id="@+id/container_4"

           android:layout_width="match_parent"

           android:layout_height="match_parent">

       </FrameLayout>

   </LinearLayout>

</com.android.prog.CustomLayout>

класс CustomLayout.java:

public class CustomLayout extends LinearLayout {

public CustomLayout(Context context) {

   super(context);

}

public CustomLayout(Context context, AttributeSet attrs, int defStyleAttr, int defStyleRes) {

   super(context, attrs, defStyleAttr, defStyleRes);

}

public CustomLayout(Context context, AttributeSet attrs, int defStyleAttr) {

   super(context, attrs, defStyleAttr);

}

public CustomLayout(Context context, AttributeSet attrs) {

   super(context, attrs);

}

public void doSomefing{//Задаём действия с элементами внутри CustomLayout

}

}

Объяснение:

ИвановичБогословский280

Если создать шаблон строки с автозаполнением, то можно немного у код:

import sys

num_steps = int(sys.argv[1])

fmt_template = '{}.{:>%d}' % num_steps

for x in range(1, num_steps + 1):

   print(fmt_template.format(x, '#' * x))

При num_steps = 4:

1.   #

2.  ##

3. ###

4.

Объяснение:

Все аргументы функции print, указанные через запятую, выводятся разделенные пробелом, отсюда и нестыковка.

Можно так попробовать:

for x in range(1, c+1):

   print('{0}{1}{2}'.format(x, " " * (c - x), '#' * x))

Для c = 3:

1  #

2 ##

3###

Либо заменить запятую конкатенацией (знак +):

print(str(x) + " " * (c - x) + '#' * x)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

напишите программу , которая считывает два целых числа a и b и выводит на экран квадрат суммы (a+b)^2 и сумму квадратов a^2 + b^2 этих чисел (python )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yelena_Gennadevna
ganorussia
алексей_Цуканов
hellomaxim
Litvin_Ivanov
mitin228133770
argent
Lenok33lenok89
dawlatowajana
Tyukalova
галина
Виталий
МАМОНОВА-андрей
avto3132
mupmalino2653