Поделитесь своими знаниями, ответьте на вопрос:
И ОБЪЯСНИТЕ ПОДРОБНО: Дано трехзначное число. Напишите программу, которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые: Пример входных данных Пример выходных данных 123 Нет 121 Да 222 Да Я не понимаю как это делать
program same;
var
number: string;
begin
read(number);
if ((number[1] = number[2]) or (number[2] = number[3]) or (number[1] = number[3])) then
writeln('Да')
else
writeln('Нет');
end.
Объяснение:
program same; // Название программы
var
number: string; // Создание строковой переменной number
begin // Начало программы
read(number); // Считываем значение переменной number с клавиатуры
if ((number[1] = number[2]) or (number[2] = number[3]) or (number[1] = number[3])) then // Если ((1 цифра = 2 цифре) ИЛИ (2 цифра = 3 цифре) ИЛИ (1 цифра = 3 цифре))
writeln('Да') // Выводим Да
else // Иначе
writeln('Нет'); // Выводим Нет
end. // Конец программы