Nadegdasb
?>

Составить программу, позволяющую в одномерном массиве вычислить количество элементов массива, не принадлежащих интервалу (a, b) (на языке C#)

Информатика

Ответы

ukkavtodor6

про асимптотику и запросы онлайн / офлайн ничего не сказано -- будем делать "в тупую" :) Ввод / вывод сделай сам, как тебе нужно, функция для просчета вот:

int count_in_range(int[] ar, int a, int b) {

   int cnt = 0;

   foreach (val in ar)

       if (a < val && val < b)

           cnt++;

    return cnt;

}

tatk00
// не совсем понял условие по которому оперделяется нужный индекс// мне показалось, что это умножение, если не так, то сам исправишь условие// выхода из цикла using System;

namespace ConsoleApplicationTest
{
    class Program
    {
        static void Main(string[] args)
        {
            double A_1 = 1;
            double A_2 = 2;
            double A_3 = (A_1 + A_2) / 2;
            Console.Write("D = ");
            double D = double.Parse(Console.ReadLine());
            int k = 3;
            while (Math.Abs(A_3 * A_2) >= D)
            {
                A_1 = A_2;
                A_2 = A_3;
                A_3 = (A_1 + A_2) / 2;
                k++;
            }
            Console.WriteLine("k = {0}; Ak-1 = {1}; Ak = {2}", k, A_2, A_3);
            Console.ReadLine();
        }
    }
}
vtarasyuk

// не совсем понял условие по которому оперделяется нужный индекс

// мне показалось, что это умножение, если не так, то сам исправишь условие

// выхода из цикла

 

using System;

namespace ConsoleApplicationTest
{
    class Program
    {
        static void Main(string[] args)
        {
            double A_1 = 1;
            double A_2 = 2;
            double A_3 = (A_1 + A_2) / 2;
            Console.Write("D = ");
            double D = double.Parse(Console.ReadLine());
            int k = 3;
            while (Math.Abs(A_3 * A_2) >= D)
            {
                A_1 = A_2;
                A_2 = A_3;
                A_3 = (A_1 + A_2) / 2;
                k++;
            }
            Console.WriteLine("k = {0}; Ak-1 = {1}; Ak = {2}", k, A_2, A_3);
            Console.ReadLine();
        }
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, позволяющую в одномерном массиве вычислить количество элементов массива, не принадлежащих интервалу (a, b) (на языке C#)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bmargarita
dimon198808744
Demina-Khokhlov584
Михеев557
Adno1578
lirene
masamosijcuk140244
mpityk
sergei-pletenev
oyudina
Илья_Ветклиники1655
natanikulina1735
Анна гутлина
korotinadasha07
losevev5619
▲