AnnaChulyukanova3
?>

НАПИСАТЬ ПРОГРАММУ НА Pascal Задача 1: Автобусные остановки Автобусные остановки расположены через каждые K метров от начала улицы, то есть на расстоянии 0, K, 2K, 3K и т.д. метров от начала. Света от начала улицы N метров, после чего устала и захотела сесть на автобус. Определите, сколько метров нужно пройти Свете до ближайшей остановки. Входные данные Программа получает на вход два целых числа K и N, записанных в отдельных строках. 1 ≤ K ≤ 2×109, 1 ≤ N ≤ 2×109. Выходные данные Программа должна вывести одно целое число — расстояние до ближайшей остановки. Система оценивания Решение, правильно работающее только для случаев, когда числа K и N не превосходят 10000, будет оцениваться в

Информатика

Ответы

yanagitsina

var

k,n,i:integer;

begin

readln(k,n);

i:=n mod k;

if i<=k div 2 then writeln(i)

  else writeln(abs(i-k));

end.

Svatela37
1)
program chik;
var a:array[1..100]of integer;
i,s:integer;
begin
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 5=0)then s:=s+a[i];
end;
write(s);
end.
 2)
program chik2;
var a:array[1..100]of integer;
i,s:integer;
begin
s:=0;
for i:=1 to 11 do
begin
read(a[i]);
end;
s:=0;
for i:=1 to 11 do
begin
if(a[i] mod 2=1)then s:=s+1];
end;
write(s);
end.
3)
program chik3;
var a:array[1..1000]of integer;
i:integer;
begin
for i:=1 to 9 do
begin
read(a[i]);
end;
for i:=1 to 9 do
begin
if(a[i] mod 2=0)then write(a[i],' ');
end;
end. 
ВайсманКреденс357

1)

var

a:array [1..15] of integer;

s,i:integer;

begin

randomize;

for i:=1 to 15 do begin

a[i]:=random(80)-20;

write (a[i],' ');

s:=s+a[i];

end;

writeln;

writeln ('Summa = ',s);

readln;

end.

2)

var
a:array [1..15] of integer;
i:integer;

p:longint;
begin
randomize;

p:=1;
for i:=1 to 15 do begin
a[i]:=random(26)+5;
write (a[i],' ');
p:=p*a[i];
end;
writeln;
writeln ('Proizvedenie = ',p);
readln;
end.

3)

var
a:array [1..15] of integer;
k,i:integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(90)-50;
write (a[i],' ');

if a[i]<0 then k:=k+1;
end;
writeln;
writeln ('Kol-vo = ',k);
readln;
end. 

4)

var
a:array [1..15] of integer;
k,i:integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(37)+1;
write (a[i],' ');
if odd(a[i])=true then k:=k+1;
end;
writeln;
writeln ('Kol-vo = ',k);
readln;
end. 

5)

var
a:array [1..15] of integer;
k,i:integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(39)+2;
write (a[i],' ');
if a[i]<20 then k:=k+1;
end;
writeln;
writeln ('Kol-vo = ',k);
readln;
end.  

6)

var
a:array [1..15] of integer;
k,i:integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(60)+5;
write (a[i],' ');
if a[i] mod 7 = 0 then k:=k+1;
end;
writeln;
writeln ('Kol-vo = ',k);
readln;
end.  

7)

var

a:array [1..15] of integer;

s,i:integer;

begin

randomize;

for i:=1 to 15 do begin

a[i]:=random(8)+3;

write (a[i],' ');

if a[i]=8 then s:=s+a[i]

end;

writeln;

writeln ('Summa = ',s);

readln;

end.

8)

var

a:array [1..15] of integer;

s,i:integer;

begin

randomize;

for i:=1 to 15 do begin

a[i]:=random(69)+5;

write (a[i],' ');

if a[i] mod 11 = 0 then s:=s+a[i];

end;

writeln;

writeln ('Summa = ',s);

readln;

end.

9)

var

a:array [1..15] of integer;

s,i:integer;

begin

randomize;

for i:=1 to 15 do begin

a[i]:=random(69)+5;

write (a[i],' ');

if odd(a[i])=false then s:=s+a[i];

end;

writeln;

writeln ('Summa = ',s);

readln;

end.

10)

var
a:array [1..15] of integer;
i:integer;

p:longint;
begin
randomize;

p:=1;
for i:=1 to 15 do begin
a[i]:=random(69)+5;
write (a[i],' ');
if a[i] mod 3 = 0 then p:=p*a[i];
end;
writeln;
writeln ('Proizvedenie = ',p);
readln;
end.

 14)

var
a:array [1..15] of integer;
i:integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(26)+5;
write (a[i],' ');
end;
writeln;

writeln (''); 

for i:=1 to 15 do 

if odd(a[i])=false then write (a[i],' ');
readln;
end.

13)

var
a:array [1..15] of integer;
k,i:integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(85)+21;
write (a[i],' ');
end;
writeln;

writeln('');

for i:=1 to 15 do

if a[i] mod 21 = 0 then begin

write (a[i],' ');

k:=k+1;

end;

if k=0 then writeln ('Elementov net');
readln;
end.

 12)

var
a:array [1..15] of integer;
k,i:integer;
begin
randomize;
for i:=1 to 15 do begin
a[i]:=random(37)+1;
write (a[i],' ');
end;
writeln;

writeln('');

for i:=1 to 15 do

if a[i]>15 then write (a[i],' '); 

readln;
end.

11)

var
a:array [1..15] of integer;
i:integer;

p:longint;
begin
randomize;

p:=1;
for i:=1 to 15 do begin
a[i]:=random(15)+1;
write (a[i],' ');
if (a[i]>2) and (a[i]<5) then p:=p*a[i];

end;
writeln;
writeln ('Proizvedenie = ',p);
readln;
end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

НАПИСАТЬ ПРОГРАММУ НА Pascal Задача 1: Автобусные остановки Автобусные остановки расположены через каждые K метров от начала улицы, то есть на расстоянии 0, K, 2K, 3K и т.д. метров от начала. Света от начала улицы N метров, после чего устала и захотела сесть на автобус. Определите, сколько метров нужно пройти Свете до ближайшей остановки. Входные данные Программа получает на вход два целых числа K и N, записанных в отдельных строках. 1 ≤ K ≤ 2×109, 1 ≤ N ≤ 2×109. Выходные данные Программа должна вывести одно целое число — расстояние до ближайшей остановки. Система оценивания Решение, правильно работающее только для случаев, когда числа K и N не превосходят 10000, будет оцениваться в
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

director3
euzdenova
euzdenova
Буянто1346
maksim1lssah575
bhg50
Chistova-Dmitrii1162
alina Korneev
Zhilinoe134
Vladimir
Ludmila777020
olofinskayae
andreokiseleo69421
Aleksandr-Andrei
dentinnsmr467