sveta1308
?>

решить задачу на Питоне, Рекурсия Задача Напишите программу, содержащую рекурсивную функцию, которая по натуральному числу n, выводит все числа от n до 1. Основная программа должна содержать ввод исходных данных (число n) и вызов функции Примеры № Входные данные Выходные данные 1 6 6 5 4 3 2 1 Запрещенные операторы: for;while;until

Информатика

Ответы

Olga-Borisovna

def allnumbers(n):

   if n == 0:

       return 1

   print(n, end=' ')

   allnumbers(n - 1)

n = int(input("Введите число n: "))

allnumbers(n)

Объяснение:

def allnumbers(n):  // Функция allnumbers, которая принимает аргумент n

   if n == 0:  // Если значение переменной n = 0

       return 1  // Выходим из функции

   print(n, end=' ')  // Выводим значение переменной n

   allnumbers(n - 1)  // Рекурсия

n = int(input("Введите число n: "))  // Вводим число n с клавиатуры

allnumbers(n) // Функция

chermen40
Информационный поток - процесс передачи информации от одного объекта другому.При этом информация может видоизменяться, кодироваться, преобразововаться из одного вида сигналов в другие.Основные устройства компьютера - клавиатура, мышь, монитор, видео плата, процессор, ОЗУ, контроллеры, запоминающие устройства(накопители).Процессор это сердце компьютера, главный наблюдатель в процессе информационных потоков компьютера.При включении процессор инициирует процесс загрузки программ из накопителей в озу, он просит котроллеры чтобы поток данных загружался напрямую, по возможности, из накопителей в ОЗУ, минуя внутреннюю память процессора.Время от времени он опрашивает устройства ввода, мышь клавиатуру, на предмет сигналов, в которых закодированны нажатые кнопки, позиции курсора, итд... Если процессор зависнет, зациклится, то нажатия на кнопки не приведут ни к чему,т.к эти устройства никто не опрашивает.Программы, выполняющиеся на процессоре, могут "попросить" процессор выводить информацию на монитор, подавая комманды.Обрабатывая эти комманды процессор, отправляет данные в видео плату, или в котроллер видеоплаты.Видеоплата, получая данные из процессора в свой видео буфер, преобразует их в аналого-цифровой формат для подачи уже в монитор через кабель.
koam20167459
"Типовой школьный" Паскаль:

// PascalABC.Net 3.0, сборка 1064
const
  k = 100;

var
  s, wd: string;
  i, j, m, n, pt, step: integer;
  Words, WordsSort: array[1..k] of string;
  InOrder: boolean;

begin
  Write('Введите строку: '); Readln(s);
  n := Length(s); pt := 1; m := 0;
  repeat
    // Пропускаем все символы до первого непробельного
    while pt <= n do
      if Ord(s[pt]) <= 32 then Inc(pt) else break;
    if pt <= n then begin
      // Выделяем очередное слово
      wd := '';
      while pt <= n do
        if Ord(s[pt]) > 32 then begin wd := wd + s[pt];Inc(pt) end
        else break;
      if wd <> '' then begin Inc(m);Words[m] := wd end
    end
  until pt > n;
  // Теперь Words содержит все m слов.
  // Отсортируем их в массиве WordsSort методом Шелла
  for i := 1 to m do WordsSort[i] := Words[i];
  step := m div 2;
  while step > 0 do begin
    for j := m - step downto 1 do begin
      i := j;
      while i <= m - step do begin
        if WordsSort[i] > WordsSort[i + step] then begin
          wd := WordsSort[i];
          WordsSort[i] := WordsSort[i + 1];
          WordsSort[i + 1] := wd
        end;
        i := i + step
      end
    end;
    step := step div 2
  end;
  // Осталось поэлементно сравнить оба массива
  InOrder := true; i := 1;
  while InOrder and (i <= m) do
  begin InOrder := (Words[i] = WordsSort[i]); Inc(i) end;
  if m = 0 then Writeln('Строка не содержит слов')
  else
    if InOrder then Writeln('Cлова упорядочены')
    else Writeln('Cлова не упорядочены')
end.

Тестовое решение:
Введите строку: слово1    слово2    слово3    слово4 слово5
Cлова упорядочены

Введите строку: слово1    слово2    слово4    слово3 слово5
Cлова не упорядочены

"Современный" вариант решения на Паскале:

// PascalABC.Net 3.0, сборка 1064
var
  s:string;
begin
  Write('Введите строку: '); Readln(s);
  var Delim:=Range(0,32).Select(x->Chr(x)).ToArray;
  var Words:=s.Split(Delim).Where(x->x<>'');
  var WordsSort:=Words.Sorted;
  if Words.SequenceEqual(WordsSort) then Writeln('Cлова упорядочены')
  else Writeln('Cлова не упорядочены')
end.

Тестовое решение совпадает с вышеприведенным.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить задачу на Питоне, Рекурсия Задача Напишите программу, содержащую рекурсивную функцию, которая по натуральному числу n, выводит все числа от n до 1. Основная программа должна содержать ввод исходных данных (число n) и вызов функции Примеры № Входные данные Выходные данные 1 6 6 5 4 3 2 1 Запрещенные операторы: for;while;until
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

airon-082054
Maloletkina-marina2
ekattatarenko
Андрееевич787
Taurus59707
davidovalbert6
Karpova
bykotatyana
dilanarthur27
Бунеева
mvv-155
aeykin
oserdyuk41
juliapierrat
asnika1989