aidapiltoyan43
?>

Написать программу, вводящую с клавиатуры целые числа и вычисляющую их сумму до тех пор, пока эта сумма не станет больше 1000. В этом случае программа должна напечатать вычисленную сумму и завершиться. (С программы Java)

Информатика

Ответы

alexk13

import java.util.Scanner;

public class Main{

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

       int sum = 0, x;

       while(sum <= 1000){

           x = sc.nextInt();

           sum = sum + x;

       }

       System.out.println(sum);

   }

}

Kochetova92

ответ:алг т;

нач

Сместится в точку(2,1);

Опустить перо;

Сместится на вектор(0,2);

Сместится на вектор(1,0);

Сместится на вектор(-2,0);

кон.

алг я;

нач

Сместится в точку(1,1);

Опустить перо;

Сместится на вектор(1,1);

Сместится на вектор(0,1);

Сместится на вектор(-1,0);

Сместится на вектор(0,-1);

Сместится на вектор(1,0);

Сместится на вектор(0,-1);

кон.

алг с;

нач

Сместится в точку(3,1);

Опустить перо;

Сместится на вектор(-2,0);

Сместится на вектор(0,2);

Сместится на вектор(2,0);

кон.

Объяснение: на таком примере делай все буквы

Радецкая264

во всех этих задачах используются 2 формулы  (объем)I=k*i; (мощность)N=2^i

1) 8=2^i => i=3, объём= 3*20=60 бит

2)вес одного символа 4096/1024=4 бит => i=4, мощность (N) = 2^i => N=2^4=16

3)12288/8=1536 байт, далее 1536/1024=1,5 Кбайт

4)для начала переведем объем кбайт и биты. (из предыдущей задачи это 12288 бит); после найдем i i=12288/4096=3. далее мощность (N)=2^3=8

5)один символ занимает 4 бита (2^4=16) 1/64 часть мегабайта = 1024 * 1024 * 8 / 64 = 131072 бита значит 131072 / 4= 32768 символов.

6)находим количество(k) 4*30*50=6000, кол-во информации (объем (I) ) из байт переводим в бит. 4500*8=36000 бит. далее находим i; i=I(объем)/k(кол-во); i=36000/6000=6. N=2^6=64.

7)может не 1,5*1023, а 1,5*10^23? N=4; i=2. находим объём 2*1,5*10^23. I=3*10^23.

8)всего двухзначных чисел 100. (00, 01, 02, 03, 04, 05, 06, 07, 08, 09, 10, 11, 12 и тд. ) значит 2^i=100. близжайшее значение i в данном случае 7. Так как если 6, то 2^6=64, 100-64=36. если i=7, то 2^7=128. 100-128=-28 (ну по факту разница в 28 единиц.) что ближе 36 или 28? следовательно ответ 7.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, вводящую с клавиатуры целые числа и вычисляющую их сумму до тех пор, пока эта сумма не станет больше 1000. В этом случае программа должна напечатать вычисленную сумму и завершиться. (С программы Java)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ukkavtodor6
nordwokintos4
Maksim Dmitrii1579
лукашова940
teya07
artemy682719
aynaakzhigitova
kseniyavaganova
yugraspets
AntonovaAvi1716
ivanlimeexpo
Petrushin482
Косоногов Иосифовна
Григорьевич915
sinicin80
▲