proporcia46
?>

написать прогу на Python. Напишите программу, которая ищет наибольшее четное число среди введенных пяти чисел. Если такого не существует, выводит фразу "not found"

Информатика

Ответы

Chopper-hinter25

num1 = int(input("Введите первое число:"))

num2 = int(input("Введите второе число:"))

num3 = int(input("Введите третье число:"))

num4 = int(input("Введите четвертое число:"))

num5 = int(input("Введите пятое число:"))

try:

     print(max([x for x in (num1,num2,num3,num4,num5) if x%2==0]))

except ValueError:

     print("Not found")

Егоркина

Відповідь:

from random import randint as randit

lst = []

tasklst1 = 0

tasklst2 = 0

tasklst3 = 0

for elem in range(10):

   random = randit( -10, 100 )

   lst.append(random)

for i in lst:

   if i == 0:

       tasklst1 += 1

   elif i > 0:

       tasklst2 += 1

   

   elif i < 0:

       tasklst3 += 1

print("Список", lst)

print("a) У списку", len(lst), "елементів")

print("b) Середнє число у списку" , sorted(lst)[len(lst) // 2])

print("c) Сума всіх елементів" , sum(lst))

print("d) Кількість нульових елементів у масиві", tasklst1)

print("f) Максимальне число у списку", str(max(lst)) + ", мінімальне число у спику", min(lst))

print("g) Кількість додатніх елементів", tasklst2)

print("h) Кількість відємних елементів", tasklst3)

Пояснення:

praktikadok

#include <iostream>

#include <algorithm>

using namespace std;

int main()

{

int n(0),m(0);

cin >> n >> m;

int matrix[n][m];

char arr[n][m];

arr[0][0] = '0';

for(int i = 0;i<n;++i){

for(int j = 0;j<m;++j){

cin >> matrix[i][j];

if(!i && !j)continue;

if(!i){

matrix[i][j] += matrix[i][j-1];

arr[i][j] = 'R';

}

if(!j){

matrix[i][j] += matrix[i-1][j];

arr[i][j] = 'D';

}

if(i && j){

matrix[i][j] += max(matrix[i-1][j],matrix[i][j-1]);

if(max(matrix[i-1][j],matrix[i][j-1]) == matrix[i-1][j])arr[i][j] = 'D';

else arr[i][j] = 'R';

}

}

}

cout << matrix[n-1][m-1];

cout << "\n";

string s;

for(int i = n-1;;){

for(int j = m-1;;){

if(arr[i][j] == '0'){

reverse(s.begin(),s.end());

s.erase(0,1);

cout << s << endl;

return 0;

}

s.push_back(arr[i][j]);

s.push_back(' ');

if(arr[i][j] == 'R'){

j -= 1;

continue;

}

if(arr[i][j] == 'D'){

i -= 1;

continue;

}

}

}

cout << endl;

return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать прогу на Python. Напишите программу, которая ищет наибольшее четное число среди введенных пяти чисел. Если такого не существует, выводит фразу "not found"
Ваше имя (никнейм)*
Email*
Комментарий*