Составить программу для вычисления значений функции y=f(x) в точках от х=х1 до х=хn c шагом Δх. При выполнении задания использовать операторы цикла с постусловием, с предусловием и оператор цикла с параметром.
var a: array[1..15] of integer; b: array[1..20] of integer; c: array[1..10] of integer; i, maxa, maxb, maxc: integer;
begin maxa := 0; for i := 1 to 15 do begin read(a[i]); if abs(a[i]) > maxa then maxa := abs(a[i]); end; maxb := 0; for i := 1 to 20 do begin read(b[i]); if abs(b[i]) > maxb then maxb := abs(b[i]); end; maxc := 0; for i := 1 to 10 do begin read(c[i]); if abs(c[i]) > maxc then maxc := abs(c[i]); end; if (maxa > maxb) and (maxa > maxc) then begin for i := 1 to 15 do write(a[i], ' ');writeln;writeln(maxa); end else if (maxb > maxa) and (maxb > maxc) then begin for i := 1 to 20 do write(b[i], ' ');writeln;writeln(maxb); end else if (maxc > maxb) and (maxc > maxa) then begin for i := 1 to 10 do write(c[i], ' ');writeln;writeln(maxc); end; end.
kot271104
10.04.2022
5. Если всего 256 цветов, то на один пиксель отводится 8 бит (2^8 = 256), что равно 1 байту. Если объем файла 120 байт, то в нём 120 точек.
6. Изображение состоит из 64 * 32 = 2^6 * 2^5 = 2^11 пикселей и под него выделено 64 Кб = 2^6 Кб = 2^16 байт = 2^19 бит памяти. Значит, на каждый пиксель отводится 2^19 / 2^11 = 2^8 = 256 бит. Максимальное допустимое число цветов равно 2^256 (это равно 115792089237316195423570985008687907853269984665640564039457584007913129639936)
7. В изображении 640 * 480 = 307200 пикселей, на каждый отводится 3 байта = 24 бита, тогда объём файла 307200 * 24 = 7372800 бит. Модему на передачу потребуется 7372800 / 56000 = 131,7 с
8. Объем файла уже вычисел, 7372800 бит. Скорость передачи 7372800 / 256 = 28800 бит/с
var
a: array[1..15] of integer;
b: array[1..20] of integer;
c: array[1..10] of integer;
i, maxa, maxb, maxc: integer;
begin
maxa := 0;
for i := 1 to 15 do
begin
read(a[i]);
if abs(a[i]) > maxa then maxa := abs(a[i]);
end;
maxb := 0;
for i := 1 to 20 do
begin
read(b[i]);
if abs(b[i]) > maxb then maxb := abs(b[i]);
end;
maxc := 0;
for i := 1 to 10 do
begin
read(c[i]);
if abs(c[i]) > maxc then maxc := abs(c[i]);
end;
if (maxa > maxb) and (maxa > maxc) then begin for i := 1 to 15 do write(a[i], ' ');writeln;writeln(maxa); end
else if (maxb > maxa) and (maxb > maxc) then begin for i := 1 to 20 do write(b[i], ' ');writeln;writeln(maxb); end
else if (maxc > maxb) and (maxc > maxa) then begin for i := 1 to 10 do write(c[i], ' ');writeln;writeln(maxc); end;
end.