Yelena1458
?>

Составьте программу на языке C++, заменяющую меньшее из двух чисел модулем разности , а большее-модулем произведения этих чисел.

Информатика

Ответы

ti2107

#include <iostream>

#include <cmath>

using namespace std;

int main()  

{

 int first, second, temp;

 cin >> first >> second;

 if (first > second)

 {

   temp = first;

   first = abs(first * second);

   second = abs(temp - second);

 }

 else

 {

   temp = second;

   second = abs(second * first);

   first = abs(temp - first);

 }

 cout << first << " " << second;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

#include <cmath>  // Библиотека с математическими функциями

using namespace std;  // Пространство имен

int main()  

{

 int first, second, temp;  // Создание целочисленных переменных:

first - первое число, вводимое с клавиатуры;second - второе число, вводимое с клавиатуры;temp - переменная, для временного хранения одного из значений.

 cin >> first >> second;  // Вводим с клавиатуры первое и второе числа

 if (first > second)  // Если значение переменной first > значения переменной second

 {

   temp = first;  // Переменная временного хранения = значению переменной first

   first = abs(first * second);  // Значение переменной first (большей) = модулю произведения двух чисел

   second = abs(temp - second);  // Значение переменной second (меньшей) = модулю разности двух чисел

 }

 else  // Иначе

 {

   temp = second;  // Переменная временного хранения = значению переменной second

   second = abs(second * first);  // Значение переменной second (большей) = модулю произведения двух чисел

   first = abs(temp - first);  // Значение переменной first (меньшей) = модулю разности двух чисел

 }

 cout << first << " " << second;  // Выводим значения переменных first и second

}

Pastel-sova
Var
a:array[1..20] of integer;
i,n,min,max,s:integer;
begin
randomize;
s:=0;
writeln ('Введи кол-во элементов в массиве');
readln(n);
for i:=1 to n do
a[i]:=random(35)-10;
for i:=1 to n do
if i mod 2 = 0 then writeln ('a[',i,']=',a[i]);
for i:=1 to n do
if i mod 2 >0 then writeln ('a[',i,']=',a[i]);
for i:=1 to n do if (a[i] mod 3 = 0) or (a[i] mod 5 = 0) then s:=s+a[i];
writeln ('Сумма членов кратных 3 или 5 = ',s); 
min:=a[1]; 
max:=a[1]; 
for i:=2 to n do begin
 if a[i]<min then min:=a[i]; 
if a[i]>max then max:=a[i];
 end; 
writeln ('Максимум=',max); 
writeln('Минимум=',min); 
end.
Telenkovav
1)uses crt;
const m=5;
n=5;
var a:array[1..m,1..n] of integer;
b:array[1..m] of integer;
i,max,min,j,k,p:integer;
begin
randomize;
for i:=1 to m do
for j:=1 to n do
a[i,j]:=random(20);
min:=20;
max:=0;
for i:=1 to m do
begin
for j:=1 to n do
write(a[i,j]:3);
writeln;
end;
writeln;
k:=1;
repeat
for i:=k to k do
for j:=1 to n do
begin
if (a[i,j]<min) then begin min:=a[i,j]; b[k]:=a[i,j]; end;
end;
inc(k);
min:=20;
until k>n;
for p:=1 to m do
if (b[p]>max) then max:=b[p];
writeln(max);
end.

2)uses crt;
const n=5;
var a:array[1..n,1..n] of integer;
b:array[1..n] of integer;
i,j,k,p,t,min,max:integer;
begin
randomize;
for i:=1 to n do
for j:=1 to n do
a[i,j]:=random(5);
for i:=1 to n do
begin
for j:=1 to n do
write(a[i,j]:3);
writeln;
end;
writeln;
k:=1;
t:=0;
repeat
for i:=1 to n do
for j:=k to k do
if a[i,j]=0 then inc(t);
b[k]:=t;
t:=0;
inc(k);
until k>n;
min:=5;
max:=0;
for p:=1 to n do
begin
if(b[p]>max) then max:=p;
if(b[p]<min) and (b[p]<>0) then min:=p;
end;
k:=1;
repeat
for i:=k to k do
//for j:=1 to n do
begin
a[k,min]:=a[k,min]+a[k,max];
a[k,max]:=a[k,min]-a[k,max];
a[k,min]:=a[k,min]-a[k,max];
inc(k);
end;
until k>n;
for i:=1 to n do
begin
for j:=1 to n do
write(a[i,j]:3);
writeln;
end;
writeln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке C++, заменяющую меньшее из двух чисел модулем разности , а большее-модулем произведения этих чисел.
Ваше имя (никнейм)*
Email*
Комментарий*