Поделитесь своими знаниями, ответьте на вопрос:
Перестановка цифр Дано трехзначное число, в котором все цифры различны (abc Напишите программу, которая выводит шесть чисел, образованных при перестановке цифр заданного числа. Формат входных данных На вход программе подаётся положительное трёхзначное целое число, все цифры которого различны. Формат выходных данных Программа должна вывести шесть чисел, образованных при перестановке цифр заданного числа в следующем порядке: abc, acb, bac, bca, cab, cba
так как число всего лишь трехзначное, то можно сделать в тупую за О(n^3):
#include <iostream>
using namespace std;
void solve(){
string num;
cin >> num;
for(int i = 0; i < 3; i++)
for(int j = 0; j < 3; j++)
for(int k = 0; k < 3; k++)
if(i != j && i != k && j != k)
cout << num[i] << num[j] << num[k] << "\n";
}
signed main(){
solve();
}