АркадьевичБундин789
?>

разобраться, как это записать в ответ? Определите значение переменной «a» после выполнения фрагмента программы: a: =10; b: =3; if a < b then b: = b + 12 else a: = a - 7; if a < b then a: = a + 12 else a: = a -7;

Информатика

Ответы

Тариелович871

Простейшая программа.

В начале у нас a = 10, b = 3.

Затем мы сравниваем а и b.

10 > 3.

Поэтому у нас выполняется "else".

a = 10 - 7 = 3

Снова сравниваем a и b.

a = b

Выполняется блок "else"

a = 3 -7 = -4

ответ: -4

Lenamihluk50

var

   n, i, aon_i, k: integer;

   f: boolean;

function AmountOfNumbers(n: integer): integer;

var

   s: integer;

begin

   s := 0;

   while n > 0 do

   begin

       s := s + n mod 10;

       n := n div 10;

   end;

   AmountOfNumbers := s;

end;

begin

   readln(n);

   

   for i := 0 to n do

   begin

       f := true;

       aon_i := AmountOfNumbers(i);

       

       for k := 2 to 9 do

           f := f and (aon_i = AmountOfNumbers(k * i));

       if f then writeln(i);

   end;

end.

Объяснение:

Феофанов_Никита1067

pascal

Объяснение:

var

 a: array [1..21] of integer;

 i, max, imax: integer;

begin

 randomize;

 WriteLn('Исходный массив:');

 for i := 1 to 21 do

 begin

   a[i] := random(66) - 13;

   Write(a[i], ', ');

 end;

 WriteLn;

 WriteLn('Результат задания 1:');

 for i := 1 to 21 do

 begin

   if i mod 2 = 0 then a[i] := -3 * a[i];

   Write(a[i], ', ');

 end;

 WriteLn;

 WriteLn('Результат задания 2:');

 for i := 1 to 21 do

 begin

   if a[i] < 10 then a[i] := - a[i];

   Write(a[i], ', ');

 end;

 WriteLn;

 max := -13;

 WriteLn('Результат задания 3:');

 for i := 1 to 21 do

 begin

   if abs(a[i]) > 40 then a[i] := a[i] - 15;

   Write(a[i], ', ');

   if a[i] > max then

   begin

     max := a[i];

     imax := i;

   end;

 end;

 WriteLn;

 a[imax] := sqr(imax);

 WriteLn('Результат задания 4:');

 for i := 1 to 21 do

   Write(a[i], ', ');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

разобраться, как это записать в ответ? Определите значение переменной «a» после выполнения фрагмента программы: a: =10; b: =3; if a < b then b: = b + 12 else a: = a - 7; if a < b then a: = a + 12 else a: = a -7;
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lovel24
Виталий
nordwokintos4
ivstigres65
kronid12
gulsinatahckeeva
Monstr13
papanovar
bd201188
Prostofil200790
Любовь-Волков1205
nyuraborova89
tol1974656
Viktorovna_Yurevna
Mark-Petrovich