inikonovich
?>

Спаскалемнадо написать программу цикл с предусловием по фото​

Информатика

Ответы

Borshchev1820

ответ:

первое фото с предусловием как был сказано.

второе фото сделано по алгоритму.

объяснение:

slspam

Объяснение:

Компилятор (цомпілер; цомпілінг программ — компиляциялаушы программа) — 1) жоғарғы деңгейлі программалау тілінде жазылған алғашқы программаны машиналық тілге (алгоритмдік тілдер, түсіндіргіш, аударғыш) түрлендіруді орындайтын компьютердің жалпы математикалық жасақтамасының құрамды бөлігі. Компилятор екі бөліктен тұрады: бірінші бөлігі — программалаушының программаны жазуы үшін пайдаланылатын алғашқы тіл, екіншісі — объектілік программаны машиналық тілде жазатын аударғыш. Қандай да бір жоғары деңгейлі тіл үшін к.

Probitbiz6

ответ на 1 задачу

Алгоритм выглядит таким образом:

ввести x, y;

если x>y то

s:=(x*y)*2;

иначе

s:=(x+y)/2;

вывод s

конец. (блок-схема прилагается в скриншоте 1)

На паскале выглядит примерно так:

var

x, y, s:real;

begin

readln(x,y);

if x>y then

s:=(x*y)*2;

else

s:=(x+y)/2;

writeln(s:2:2);

end.

ответ на 2 задачу

Тут идентичный алгоритм: вводим 2 переменные x, y, далее создаем условие и возводим в модуль... (скриншот 2 с блок-схемой)

ответ на 3 задачу

Тут тоже.. в условии указываешь просто a<b<c, если условие верно, то выводишь "Верно", иначе "Не верно".

На паскале выглядит примерно так:

var

a, b, c:integer; {если число вещественное}

begin

readln(a, b, c);  

if (a<b<c) then

writeln("Верно");

else

writeln("Неверно");

end.

ответ на 4 задачу

 На паскале:

var

a, b, c, max:integer;

begin

max:=0;

readln(a,b,c);

if max<a then

max:=a;

if max<b then

max:=b;

if max<c then

max:=c;

writeln(max);

end.

 ответ на 5 вопрос

На паскале:

Var

a,b,c:integer;

begin

readln(a,b,c);

if (a<0) then

a:=a*a;

writeln(a);

if (b<0) then

b:=b*b;

writeln(b);

if (c<0) then

c:=c*c;

writeln(c);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Спаскалемнадо написать программу цикл с предусловием по фото​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annodomini1
mtcover
Горностаева831
Наталья_Васищев
lovel24
АнастасияAndrey
Бабур
ivanpetrovichru1801
Ольга
Dato24043846
mos-5nica
aidapiltoyan43
Baidina
Anastasiamoscow80
Ляпунов_Владмирович
▲