Sergei-Gradus199
?>

подскажите Определите значение переменной «a» после выполнения фрагмента программы:a := 10;if a< 5 thena := a + 12elsea := a - 7

Информатика

Ответы

Kamil

Объяснение:

1.

//  описание функции, ее можно менять

function func(in_x:real):real;

begin

 func:=-2*in_x*in_x*in_x*in_x*in_x + 4;

end;

var

 h:real;

 x:real;

 a, b:real;

 count_otr:integer;

begin

 writeln('Input a = ');

 readln(a);

 writeln('Input b = ');

 readln(b);

 writeln('Input h = ');

 readln(h);

 count_otr:=0;

 x:=a;

 while (x <= b) do begin

   {writeln('x = ', x:3:3, ' f = ',  func(x));}

   if (func(x)<0) then count_otr:=count_otr + 1;

   x:=x+h;

 end;

 writeln(count_otr);

 readln;

end.

2.

function func(in_x:real):real;

begin

 func:=-2*in_x*in_x*in_x*in_x*in_x + 4;

end;

var

 h:real;

 x:real;

 a, b:real;

 f_min, x_min:real;

begin

 writeln('Input a = ');

 readln(a);

 writeln('Input b = ');

 readln(b);

 writeln('Input h = ');

 readln(h);

 x_min:=a;

 f_min:=func(a);

 x:=a+h;

 while (x <= b) do begin

   {writeln('x = ', x:3:3, ' f = ',  func(x));}

   if (func(x)<f_min) then x_min:=x;

   x:=x+h;

 end;

 writeln('x min = ', x_min:3:3, ', f min = ', func(x_min):3:3);

 readln;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

подскажите Определите значение переменной «a» после выполнения фрагмента программы:a := 10;if a< 5 thena := a + 12elsea := a - 7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

madjk
ev89036973460
zubritskiy550
alekseysokolov29816
Борисовна_Кашутина
maltes
igschuschkov6211
Юрий197
Татьяна
lazu8375
vladimirkirv
s2010av565
zaalmix
germanleon
llmell6