af-rc7893
?>

На вход программы подается текст на английском языке, заканчивающийся точкой (другие символы точка в тексте отсутствуют Требуется написать программу, которая будет определять и выводить на экран английскую букву(в верхнем регистре), встречающуюся в этом тексте чаще всего, и количество там таких букв. Строчные и прописные буквы при этом считаются не различимыми. Если искомых букв несколько, то программа должна выводить на экран первую из них по алфавиту. Входные данные На вход программы подается непустой текст на английском языке, заканчивающийся точкой (другие символы точка в тексте отсутствуют). Выходные данные Один символ - заглавная английская буква и через пробел число - количество таких букв в строке. Пример: Ввод It is not a simple task. Yes! Вывод I 3 Ввод A. Вывод B 4 Ввод Bb Aa Cc A. Вывод A 3 Желательно на Питоне или Паскале!

Информатика

Ответы

Феофанов_Никита1067

def letter(text):

   text=text.split('.')

   text=text[0]

   text=text.split()

   text=''.join(text)

   text=text.upper()

   d={}

   for i in set(text):

       d[i]=text.count(i)

   maxim=max(d.values())

   s=0

   for k in d.values():

       if k==maxim:

           s+=1

   

   if s==1:

       for j in d:

           if d[j]==max(d.values()):

               return(f'{j} {d[j]}')

   else:

       qq={}

       for z in d:

           if d[z]==max(d.values()):

               qq[z]=max(d.values())

               

       for l in qq:        

           if l==min(qq.keys()):

               return(f'{l} {qq[l]}')

           

def runner():

   print(letter('It is not a simple task. Yes!'))

   print(letter('A'))

   print(letter('Bb Aa Cc A'))

runner()    

   

Объяснение:

Объяснение писать долго и неудобно) но если кому интересно, могу рассказать, например, через вк или дискорд. Напишите мне в личку

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программы подается текст на английском языке, заканчивающийся точкой (другие символы точка в тексте отсутствуют Требуется написать программу, которая будет определять и выводить на экран английскую букву(в верхнем регистре), встречающуюся в этом тексте чаще всего, и количество там таких букв. Строчные и прописные буквы при этом считаются не различимыми. Если искомых букв несколько, то программа должна выводить на экран первую из них по алфавиту. Входные данные На вход программы подается непустой текст на английском языке, заканчивающийся точкой (другие символы точка в тексте отсутствуют). Выходные данные Один символ - заглавная английская буква и через пробел число - количество таких букв в строке. Пример: Ввод It is not a simple task. Yes! Вывод I 3 Ввод A. Вывод B 4 Ввод Bb Aa Cc A. Вывод A 3 Желательно на Питоне или Паскале!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Михайлов
gaydukov5706
re-art
ecogoi
Anatolevna
Vyacheslavovna1867
moskvichkabakery56
Fedorovich309
КузменковаЖигулин
zatoichi69
zhandarmova
sergeymartyn56
Николаевич
parolmm
andruhovich