ann328389
?>

Составить программу на языке Паскаль. Даны два целых числа. Найти их произведение если сумма этих чисел кратна трем, иначе увеличить входные числа вдвое.

Информатика

Ответы

d5806252

2) Вопрос не понял, но думаю правильно ответил:

var a,b,c,d :int64;

begin

readln(a);

b := a -1;//число до  

c := a +1;//число след.

writeln('Число до: ',b,' Число след.: ',c);

end.

3)

var a,b,c,d :int64;

begin

readln(a);//Кол-во учеников

readln(b);//Кол-во яблок

c := b div a;//Яблок каждому ученику

d := b - (a * c);//Яблок в корзине  

writeln('Яблок каждому: ',c,' Яблок осталось в корзине: ',d);

end.

4)

var a,b,c,d:int64;

begin

readln(a);//Число

b := a mod 10;//остаток от деления

c := a div 10;//деление без остатка

d := c mod 10;//остаток от деления

writeln('При последнее число: ',d,' Последнее число: ',b);

end.

5)

var a,b,c,d:int64;

begin

readln(a);//Автобус за день  

readln(b);//Кол-во дней

c := a * b;

writeln('Автобус проехал: ',c,' (км)');

end.

6)

var a,b,c,d:int64;

begin

readln(a);//Путь муравья

b:= a div 1000;//м

c:= (a - (b*1000)) div 10;

//см

d:= a - (b*1000+c*10);

//мм

writeln('Путь муравья: ',b, ' (м) ',c,' (см) ',d,' (мм)');

end.

7)

var a,b,c,d:int64;

begin

readln(a);//Грань куба

b := a*a*a ;

writeln('Объем куба: ',b, ' м^3');

end.

8)

var a,b,c,d,g:real;

begin

readln(a,c,d,b);//Числа

g:=(a+c+d+b) / 4 ;

writeln('Cреднее арифметическое: ', g);

end.

9)

var a,b,c,d:real;

begin

readln(a,b,c);//Учеников в кадом классе

d:= (a+b+c)/ 2;

writeln('Кол-во парт для 3 классов: ', d);

end.

Объяснение:Все программы написаны на Pascal.

Капец много задач за 5б)))

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке Паскаль. Даны два целых числа. Найти их произведение если сумма этих чисел кратна трем, иначе увеличить входные числа вдвое.
Ваше имя (никнейм)*
Email*
Комментарий*